cancel
Showing results for 
Search instead for 
Did you mean: 

Armoury Crate keeps installing

UnnamedPlayer
Level 8

Hi, I stumbled upon aarmoury crate bug, i saw od reddit that it happened before to people. But in my case i tried every solution i found online. I've tried reintalling it, using windows, using asus armoury crate uninstall tool, installing it from windows store etc. 

Every time i launch AC it keeps asking for permission to change sth in my user account. Next step is always run it again to complete install and from there it shows this 

UnnamedPlayer_0-1712741001818.png

I'm on Strix Scar 18 last year. Its sad for me that i paid so much money for laptop for my studio and i have problem with its software. Now i dont have 3 modes from asus, especially silent mode for work. I hope maybe someone here will be able to help me...

417 Views
7 REPLIES 7

krniranjan12345
Level 8

im also facing same issue  , i wrote email to service center of asus ,they are telling me same thing i.e.

 Steps 1. If Armoury Crate had been installed before, please use Armoury Crate uninstall Tool.

Steps 2. Please re-install Armoury Crate through Armourycrate installer.

i did this process 10-20 times but "nothing happened."

Same thing here, i hope they will patch that update soon. I tried not updating AC now. I will update you bro if this helps. Imagine spendong 4 salaries in Poland to buy laptop and have software problems whole the time. I love Asus but this is simply sad...

i did it for the 50th time and it worked for 3 days 😞 today i launched my laptop and AC was running slowly and i saw same thing... permission to user, run sth as admin etc. reinstall. Same story begins

UnnamedPlayer_0-1713299778028.png

UnnamedPlayer_0-1713299861780.png

 

 

let see how many years it will take to fix it 😩

UnnamedPlayer_0-1714840298317.png

now this, new window keep showing up

armoury crate got installed and working fine. i dont know how 😅 

fellow these steps and see this working for you or not 

turn off virtual machine platform & windows hypervisor platform in " turn windows feature off or on". 

uninstall android emulator ( in my case i installed WSA  i.e. windows subsystem for android )

now try to install armoury crate , if it didn't work then try to install it 10-20 days later