cancel
Showing results for 
Search instead for 
Did you mean: 

Armoury Crate installation tips

Jimbo93
Level 12
**Edited info about AI Suite 3 and Prefetch on 5-12-22 based on better info and results.

** New recommendation for a possible quick fix for many issues. I have 2 posts on the subject. Latest is in another thread here: https://rog.asus.com/forum/showthread.php?117241-Problem-with-RGB-lighting/page2#post863163
I first reported it later in this thread here: https://rog.asus.com/forum/showthread.php?128812-Armoury-Crate-installation-tips/page3#post862991

Depending on the severity of your issues the rest of the info below is intended to get it running right but some of it is fairly involved.

Hi I have an intel desktop system, the details are in my profile if you like to see them. I had my share of difficulties with AC 5.1.5, sorted it out finally.


Problems I encountered


1. It needed a fix for the keyboard, the developers took care of it after I sent my log
2. Installation errors 504 and 101 that say restart and check internet connection
3. RGB basic animation stuttering and the app saying it needed to turn on performance mode
4. Updates resulting in poor performance like #3 above.

*5. Using the uninstaller Armoury Crate - Support (asus.com) and installing again and running the installer 2 or 3 times after just rebooting (more than once) does not fix the issues you are experiencing.

** Definitely try just uninstalling with the tool and installing again and if you get a network error just restart and run the installer again.... Do that stuff before considering all the suggestions I have compiled. This list is a compilation of steps to cure whatever ails.


IMPORTANT: These suggestions WILL NOT help if the AsusCertService.exe is not running properly on your system. Check it is running with Task manager-details tab or check windows event log Application log (there should be an Event 0, AsusCertService - "The operation completed successfully" event logged there immediately after system startup.

1a. I recommend you turn off XMP memory overclock or cpu overclock during this process. If you have a usb flash drive just save your bios profile if this is a concern, and then you can reload it afterward.

1b. Update your bios to the latest from Asus support page and/or set your bios to defaults. Note that you may need to check your TPM setting is correct after setting defaults.

2. Update your hardware drivers (I recommend using MoKiChU's driver packs. https://rog.asus.com/forum/showthread.php?119120-INDEX-All-My-Firmware-Drivers-Software-Threads


3. Use Driver store explorer to remove old drivers from you driver store, this app is shared by MoKiChU also in his driver threads.


4. How to reinstall chipset drivers? MoKiChU has the answer for intel chipset here https://rog.asus.com/forum/showthread.php?117609-DRIVERS-Intel-Chipset-MEI-SATA-VMD-(1xx-2xx-3xx-4xx...


*** THIS #5 IS NOT NECESSARY, I have a had good result (but no windows fan control) with just installing Armoury Crate, AND with installing AI Suite 3 after installing Armoury Crate. AI Suite 3 is good software I had it all working, but it does not allow to turn on virtualization and memory integrity for device security. I decided I need that more than windows fan control. 5.I used to think I need to install AI Suite first for the best system performance, not true anymore.

Still good info here #6 especially if you want to strip AI Suite 3 out all the way.

6. (EDITED twice) And more information on AI Suite 3.
There is a cleaner app for completely removing it on your Asus support page. To get the best results:

PAUSE windows updates FIRST. Just go to windows settings and windows updates and hit the pause button. You can come back and hit resume after this step 6 is complete.

Uninstall A.C. with the uninstall tool, uninstall AI Suite 3 from windows settings-Apps, Remove Aura device drivers with device manager or with driver store explorer. For example I have 2 drivers that must be removed rogkb.inf and rogms.inf as seen with driver store explorer. Reboot then run the AI Sute 3 Cleaner. Run AI Sute 3 Cleaner a second time to make sure everything is removed.

7. This doesn't take long to do. With A.C uninstalled and AI Suite 3 uninstalled use windows troubleshooter to make sure things are ok. Open the windows control panel-Troubleshooting. Run the following troubleshooters:
a. Windows Update troubleshooter
b. Search and Indexing troubleshooter - select the option files and folders are not showing
c. Power troubleshooter
d. System maintenance troubleshooter
e. Windows store apps troubleshooter
f. Restart the computer


8. How is your network connection? If you have less than reliable network 100% of the time it is probably worth your time to investigate and correct.

*Probably not necessary, probably, but I dont like having multiple identical entries in my firewall rules and I have reinstalled AC many times.
9. Remove the few firewall entries that the A.C. uninstaller left. This is not difficult. Control Panel or search for Windows Defender Firewall. Open it, select Advanced settings, then select inbound rules. Remove the following entries should be near the top:
a. ArmouryHtmlDebugger
b. ArmourySocketServer
c. FrameworkService


10. Run the windows Disk Cleanup as Administrator and select temporary file categories


11. Recompile .NET. Use Windows System Maintenance under Control Panel, Security and Maintenance, Start Maintenance. Or if you are in a hurry:

a. Open 2 administrator command prompts
b. In one of them execute these two commands
i. CD C:\Windows\Microsoft.NET\Framework\v4.0.30319
ii. ngen executequeueditems
c. In the other command prompt execute these
i. CD C:\Windows\Microsoft.NET\Framework64\v4.0.30319
ii. ngen executequeueditems
d. Go back to first command prompt and execute
i. ngen update
e. In the second command prompt execute
i. ngen update


*THIS IS NO LONGER CONSIDERED A BIG HELP. I have not had to resort to this in quite some time now, there are better solutions. 12. Just for the purposes of installing software, temporarily disable windows prefetching. This may make a big difference for you and is definitely worth trying. Use windows registry editor and go here
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters
Note the current setting for the value called EnablePrefetcher. Change it to zero and restart the system. After all installation and updates of A.C. are done put it back to original setting and restart again.


13. If you are still having trouble, uninstall everything again and follow these steps

a. In an Adminstrator command prompt execute: DISM /ONLINE /CLEANUP-IMAGE /RESTOREHEALTH
b. RESTART the computer.
c. In an Adminstrator command prompt execute: SFC /SCANNOW
d. In the same Admin command prompt execute: CHKDSK /X /F - answer yes and reboot.

14. You can run the installer a second or even third time to get past the internet connection failure, without running the uninstaller again.

15. There are also drivers installed by windows update for some (all?) Aura devices that can be removed just from device manager or by using driver store explorer. I refer to Keyboard drivers, mouse drivers etc. Edited: I think this is only necessary if you have also used AI Suite 3 at some time.

Hope it helps someone. Feel free to post your suggestions or questions to this thread.
14,917 Views
39 REPLIES 39

Thanks. The error I had with the keyboard that was fixed by a very recent update was a 2006 device page error.

About those drivers, I had two that I removed, they would both get reinstalled for me just by checking for windows updates. hmmm, Im not familiar with ROG Armoury II software or Driver booster.

Bushmaster78FS wrote:
Very nicely done mate, good instructions. I suffer from device page error 2005/2006 in AC so I used this method, at the very least it fixed an issue I was having with AISuite3, (GPU wasn't showing) and AC uninstalls and reinstalls fine (reinstall only in the second attempt, first attempts are always ending up with internet 101 error) AC is fully functional with the exception of getting into the device pages.

One caveat though, deleting the .inf files of input devices from DriverStoreExplorer had some unexpected side effects. Reinstalling the Armoury Crate didn't reinstall these drivers back. So when all said and done with the Armoury Crate installation, I went and did a driver scan with both Windows Update and Driver Booster. The latter installed the drivers back on along with ROG Armoury II software.

Jimbo93 wrote:
Thanks. The error I had with the keyboard that was fixed by a very recent update was a 2006 device page error.


So hopefully an update will come around and fix the device page errors I am having.

About those drivers, I had two that I removed, they would both get reinstalled for me just by checking for windows updates. hmmm, Im not familiar with ROG Armoury II software or Driver booster.


ROG Armoury II is their older device profile software prior to Crate. Back then they had a different software for everything. IObit Driver Booster is just a huge driver repository software, a bit more in depth than Windows Update, you can check out the interface using a virtual machine like the Sandbox. I am assuming they paired the drivers with their software. Not a big deal as ROG Armoury allows access into the mouse and keyboard profiles once they are unsynced from Aura lighting in Crate.

Adding some additional information about AI Suite 3 configuration for anyone that may use it with Armoury Crate. You may or may not know that some AI Suite 3 functions are not compatible with windows/system virtualization turned on. But there is a workaround that I am using.

Why use virtualization? Well, it is supposed to improve protection against malware for one reason, and a second reason is that it is required to use WSL2 (windows subsystem for linux).


So the workaround is: you need to disable the away mode settings in AI Suite 3, and disable the task for Asus DIPAwayMode. This task can easily be disabled with windows task scheduler. The task to disable can be found in the Asus folder. I will attach a screenshot. 92867
You may need to turn off virtualization in the bios and uninstall the feature from windows features to get AI Suite installed and configured as described. Once that is done you can turn on virtualization in the bios and add the feature "Virtual Machine Platform".

Nate152
Moderator
Hey Bushmaster78F5,

Is everything back to normal and working ok?

I got the 1003 error one time with the ROG Falchion NX, the only thing that fixed this particular error was a fresh windows reinstall.

Nate152 wrote:
Is everything back to normal and working ok?


No unfortunately, this method didn't fix the Device Page error 2005/2006 and that is the only problem I am having with AC. The amount of device page errors I am seeing from people makes me think that a fresh Windows install may also get the same problem with the current iteration of Armoury Crate, so I don't think I want to reinstall Windows 11. My OS works flawless at the moment, I just reinstalled it like 10 days ago, I am kind of tired of reinstalling Windows at this point.

Nate152
Moderator
I will suggest to do a fresh reinstall of windows, this usually fixes any problem with Armoury Crate and I'm confident it will fix the Device page error.

Nate152 wrote:
I will suggest to do a fresh reinstall of windows, this usually fixes any problem with Armoury Crate and I'm confident it will fix the Device page error.


I am absolutely confident that it would fix the error but it is also likely Armoury Crate may get broken again. So I just read someone who just reinstalled their Windows had their Armoury Crate start giving the device page error. That is a huge hassle to go all through and fall back to square one. Likely I will wait until next AC update and see if they fix it that time.

HumbleSiPilot77
Level 10
I ended up not installing AISuite3 after my Windows reinstallation. My mobo is stuck with 3.00.51 or something version anyway and ASUS never released anything after that. Set my fans and OC with the BIOS, happy camper 🙂

Bushmaster78FS wrote:
I ended up not installing AISuite3 after my Windows reinstallation. My mobo is stuck with 3.00.51 or something version anyway and ASUS never released anything after that. Set my fans and OC with the BIOS, happy camper 🙂


Cool man. I am experimenting myself with and without. Once I figured out how to get the Cleaner to clean it completely, I thought there was a good chance I could get better performance out of AC if I worked on it. Turned out true, eventually. And to describe the performance issue I have to deal with, its a higher than normal cpu activity with the motherboard hal process. Reinstalled AC without AI Suite and that same problem was there. It eventually calmed down hours later and after some fiddling. I can only hazard a guess that it kind of cured itself. I am also using your method for fan control to see how I like it.

HumbleSiPilot77
Level 10
Jimbo93 wrote:
I am also using your method for fan control to see how I like it.



For the same profiles, BIOS fan settings seem to be a bit quieter. I fined tuned the AI3 as much as I could but there would always be a fan spike here and there. BIOS is pretty smooth.


Also an irrelevant question, but you may know the answer.





I use the Aura Sync smart effects based on CPU temperature for a couple Aura devices, but for the life of me I couldn't figure out which mobo sensor below does Armoury Crate utilize to change the lighting...





I am assuming it is the last one, below the PECI as it kind of matches when I do a stress test.