cancel
Showing results for 
Search instead for 
Did you mean: 

Armoury Crate > can't manage devices

Guz792
Level 8

HI,
It's been a few days I can't manage the devices in Armoury Crate.
I see them listed correctly but if I select any one to manage it, the black loading screen starts and after few seconds Armory Crate close itself.
I have already tried uninstalling it with the tool and reinstalling it but the problem persists.
Version 5.8.9.0
Windows 11

2,304 Views
22 REPLIES 22

Guz792
Level 8

Hi, sorry for the late reply but I've been away for a few days.
However no, I hadn't solved it before but yesterday there were some updates in Armory Crate and after those it now works normally and no longer self-closes when I manage the devices.

giyotin1982
Level 7

Hello, I have been having the same problem for 3-4 months and even tried for days to fix it, but I couldn't solve it, and I haven't seen anyone who can solve it.
i finally solved the problem today and it's such a simple solution that I'm angry at myself.
i block the edge browser every time I format my computer because it uses unnecessary resources. But I learned that the current version, Armory Crate, requires Microsoft Edge and I wanted to share this information with you.ScreenHunter_01 May. 10 18.36.jpg