Showing results for 
Search instead for 
Did you mean: 

Armoury Crate > can't manage devices

Level 8

It's been a few days I can't manage the devices in Armoury Crate.
I see them listed correctly but if I select any one to manage it, the black loading screen starts and after few seconds Armory Crate close itself.
I have already tried uninstalling it with the tool and reinstalling it but the problem persists.
Windows 11


Level 8

ROG Live Service is running. I restarted it but the problem doesn't go away, Armory Crate keeps self-closing when I try to manage any device.
The motherboard is a ROG Crosshair VIII Extreme.
The BIOS is updated to the latest version, 1505, and the framework is also updated, v.


Thank you

I haven't experienced this particular problem with Armoury Crate closing on its own, and tracking down the fix is starting to prove difficult.

Are all your drivers up to date?

1) Graphics driver

2) Chipset driver - I see there are two chipset drivers at the ASUS Support Center, have you updated to the most recent one? If you haven't, uninstall your current chipset driver and update to the latest one.

To uninstall the chipset driver, open Control Panel, click Programs, click Programs and Features, click Uninstall a Program. Scroll to AMD Chipset Device Software, right click on it and click Uninstall.

I'm using Intel, yours will show AMD.

Uninstall Chipset driver.png

Once uninstalled, reboot your pc and install AMD Chipset driver V3.10.22.706, it's the first one in the Chipset list.

ROG Crosshair VIII Extreme (

3) If those didn't help, a suggestion is to disable fast startup.

Uncheck Turn on fast startup and click Save changes at the bottom. Reboot and try Armoury Crate.

Fast Startup.png


Level 8

So, as soon as I have time I will check point by point the whole things to check that you wrote to me before.
In the meantime I have good and bad news.

The good news is that after updating the bios yesterday I tried to reset the parameters to keep the motherboard's RGB turned off with the PC in sleep mode and now it works! Armoury Crate continue self closing when I try to manage devices but at least at night I can now sleep without LEDs pointed in my face xD

The bad news is that after the BIOS update, PC no longer detects disk drive 😧
It sees all the others (C, E, F and G) but not the Samsung NVME which was saved as D and where several programs were installed.

Screenshot 2024-04-13 110503.png




Furthermore, if I go to Disk Management it almost seems to detect it as a C partition which should be 1TB not partitioned.

Screenshot 2024-04-13 110605.png

Level 8

UPDATE: 😧 unit problem solved
The PCIe parameters reset when updating the BIOS and I didn't notice.
This motherboard by default powers only the first M2 slot and to enable the other 2 there is a setting to change. Resolved.


I'm glad you were able to find the problem.

So, is Armoury Crate working now?




Hi i have a similar problem

i cant open my motherboards device settings in armory crate so i cant get the rgb to turn off when i turn the pc off

A z790-h

Thank you

Try uninstalling Armoury Crate from windows then reboot your pc.

Install Armoury Crate Once installed, head to the Armoury Crate update Center and check for updates.

Armoury Crate - Support (


AC uninstall.png

I have already tried uninstalling with the asus uninstaller where it did not help

now i tried to uninstall from windows and now it works so thank you for helping me