Showing results for 
Search instead for 
Did you mean: 

Armoury Crate > can't manage devices

Level 8

It's been a few days I can't manage the devices in Armoury Crate.
I see them listed correctly but if I select any one to manage it, the black loading screen starts and after few seconds Armory Crate close itself.
I have already tried uninstalling it with the tool and reinstalling it but the problem persists.
Windows 11



Hello Guz792

What version of the installer did you use?

Try uninstalling Armoury Crate from windows, then reboot your pc.

Once rebooted, install Armoury Crate version, then go to the Armoury Crate update center and check for updates.

Armoury Crate - Support (

ac uninstall.png


I have always used the uninstallation tool by downloading it from the official support page so it is the most updated version.
This evening as soon as I get home I'll try to uninstall it from Windows as you say.

Ditto for the installation, I have always used the most recent package ( downloaded just last night and once installed I have always made all the available updates (except the ROG Spatha which for some reason sometimes doesn't work even if I connect both the mouse and the dongle with cable).

I'll update you as soon as I try again.


All right, sounds good. Hopefully, we'll kill two birds with one stone.

It sounds like you're doing the update correctly for your ROG Spatha, I'll list the steps just to be sure.

You can have it set up like this before doing the install. That way, when Armoury Crate is updating, all you'll have to do is click update.

1) Connect one of the cables to the wireless charging dock and a pc usb port, be sure the cable is fully inserted at the dock end.

2) Connect the other cable to your ROG Spatha and a pc usb port.

3) Set the wireless switch on the bottom of the Spatha to wired mode.

4) Try the update in Armoury Crate.




Level 8

I tried again but nothing, there is no way to enter in the device settings. It loads for a few seconds and then the entire app closes.
I only solved the mouse update problem (it was a cable problem).

The problem is that I wanted to disable the RGB lighting on the motherboard with the PC turned off but if I can't access the devices I can't. I tried to deactivate it from the Bios but when I start the PC Armory Crate overwrites the value by reactivating them.

Screenshot 2024-04-11 204740.png


All right,

Good to hear you're making progress with one problem solved.

You could try resetting the bios to default settings. (In the bios hit the F5 key) 

Doing some research, some are saying that setting the operating system to the English language solved the issue of Armoury Crate not loading and closing automatically.




I changed the language but it doesn't work
I reset the bios but it doesn't work :'(


Thank you for trying and sorry to hear that didn't work.

Don't worry, I'm not giving up on you.

Sometimes windows dynamic lighting can interfere with Armoury Crate, try turning off the windows dynamic lighting.

Under background light control, check that Armoury Crate is at the top of the list. If it's not, click on Armoury Crate, hold the click and move it to the top of the list.

After doing this, for good measure, restart Armoury Crate and see if you're able to access your devices.

dynamic lighting.png


Level 8

I turned off dynamic lighting but it still doesn't work.
Armory Crate is also not listed below.

Screenshot 2024-04-12 002506.png


All right,

I don't mean to run you in circles, hopefully we will soon come across the fix. 

Check windows update for updates.

What motherboard are you using? Update to the latest bios version if you haven't already.

Open task manager, click services, check that ROG Live Service is running. If it is running, try stopping it and starting it again.

ROG Live Service.png