cancel
Showing results for 
Search instead for 
Did you mean: 

Armoury Crate Error H-2005

Papa_Baphomet
Level 8

Hello all.
So just a couple of days ago I got myself the ROG Azoth keyboard.
As stupid as it sounds, I got it only because of the oled screen to be able to upload my own pics and gif's.
After installing the official Armoury Crate, when trying to access the keyboard setup - it loads for several minutes and then gives me the H-2005 error.

I do also have an ASUS motherboard and it get's the same error. But I don't really care aboth that as I don't need to configure anything with the motherboard.

I found similar topics on this forum:

https://rog-forum.asus.com/t5/armoury-crate/error-2005-help-please/td-p/888942/page/2

and
https://rog-forum.asus.com/t5/armoury-crate/error-with-the-device-page-error-2006/td-p/908266/page/4

Obviously I went with the simplest solutions like fully uninstalling the software with the Uninstaller tool.
I already have both Edge and Chrome on my PC.

And if that doesn't help, the Moderator offers to re-install windows?
Seriously?

An International company with thousands of employees all around the world, creating all kinds of hardware offers to just re-install WIndows?

This is definitely not an option for me.

I'm not sure if this issue was even properly investigated. This issue is over a year old and still hasn't been fixed.

This $320 keyboard is currently useless for me so I'd really like to at least know what causes this error.

I never had any similar issues with software from other manufacturers.

Any help is appreciated.

 

2,300 Views
6 REPLIES 6

Papa_Baphomet
Level 8

UP

hi i been getting the same issue as well...unable to modify Ryujin,Rog Chakram, strix flare or anything....any luck yet?

 

No luck.
I also found this Reddit topic which looked promising:
https://www.reddit.com/r/ASUS/comments/mkwoi9/armoury_crate_rog_spartha_theres_an_error_with/

One dude advised to delete the device drivers and then re-connecting the device.

That didn't work for me.

I'm also in touch with the official Asus support via e-mail.

But they don't help at all. It's all over again: Install edge, Install Chrome, re-install Crate etc.

josh_yy
Level 8

same problem here, and still haven't seen any useful message. I wonder if they really care about their users,

Papa_Baphomet
Level 8

Well, miraculously, it started working and I have no idea what I did right.

This is how it happened.
I was in touch with Asus support and they asked me to record my screen and log the error.

So I reinstalled Crate, went to settings and enabled the logger, unplugged the keeb, plugged it back and....it worked.
All I can say is....God's ways are mysterious
But now for some reasong I can't upload any custom images lol

 

 

I hope it lasts. For me it works for several days after an install then the issues start again.


Cooler Master Silent Pro Hybrid 1300W ATX
Asus ROG Maximus Z690 Extreme
Intel Core i9-12.900k
ROG Ryujin 360
Corsair DDR5 Dominator Platinum RGB 2x32GB 5600Mhz
Samsung 980 PRO 2TB M.2 SSD (2x)
Seagate Firecuda 1TB
ROG RTX3080-O10G-Gaming
Monitor 1: ROG STRIX XG349C
Monitor 2: Samsung HDTV T27D590
ROG Claymore
ROG Spatha X
ROG Balteus Qi
Windows 11
😉