Showing results for 
Search instead for 
Did you mean: 

Armoury crate doesn't find my mobo/ARGB/RAM but finds others

Level 7
I've seen a million threads on this so I'm not expecting something that results in a solution. But, they are older posts, so who knows, maybe someone from Asus will read this and one day the issue will be resolved. My system:

Asus Crosshair VIII Formula BIOS version 3302 (I've tried 3402 as well, not trying the current beta BIOS).
AMD 5950x
Windows 10x64
32GB Trident G.Skill RAM
Mouse: Asus ROG Spatha

I installed Armoury Crate v3.0.11.0 from my motherboard's download section. After installing and rebooting it detects the Spatha just fine. I can fully configure the mouse. Yay. However, the motherboard/RAM/ARGB headers do not show up under either lighting effects or devices. In the BIOS, Aura mode is set to all on. I've tried holding the reset CMOS button (with cable unplugged) for 10ish seconds. I've tried removing the CMOS battery (again, unplugged) for 7 minutes (timed it), tried loading defaults via F5 all same results: Motherboard and ARGB headers never detected.

Not really sure what else to try. There are no other lighting related software products installed. I don't have iCue installed, nor anything to bling out my video card. I don't even have the Trident G.Skill RGB software installed.

I even at one point had a ROG Ryujin AIO cooler: The software detected this and I was fully able to configure it. I just yesterday swapped it out for something better though that gives me way better thermals. Anyway, point is, the software seems to reliably detect everything except the mobo and whatever components rely on the mobo for lighting support. I'm not sure if this is due to the rapid pace of the BIOS updates and the AGESA/USB issues, like perhaps some lighting bug got introduced and it's just low on the priority list. But anyway, figured I'd post and see if anyone's had a solution.

So far I've only either seen: "Deal with it, it's a buggy mess", or some random voodoo that worked for one guy but no one else. I'm guessing the answer is "Deal with it, it's a buggy mess."

Level 7
I did a fresh reinstall of Windows yesterday because armoury crate was broken, never in my life have I seen a piece of software so broken that it become unusable without even touching it.

Here's exactly what I did:
-> Wiped my whole computer and reinstalled a fresh copy of windows 10 pro x64
-> Installed the drivers and a couple softwares (basic stuff like firefox)
-> Installed armoury crate, and did my peripherals config (My mouse, keyboard, headset and motherboard are all from Asus)
-> For exactly one day, the software works as it's supposed to, ( I see the devices inside it and I'm able to change the config)

-> Today, Open the software, it's broken again , no device is showing up and I get an error message saying that the service is not started.
-> Go inside windows look at the services that are running, AsusROGLSLService Download ROGLSLoader is stopped and won't start.

Does Asus do any QC on this software ? How can you force all your users to use such a broken pieces of garbage software and not give a damn about it ?

Community Admin
Community Admin
Hi guys, Armoury Crate V4.1.6.0 is available if you haven't updated. If you are still experiencing issues, please post in the thread below:

Do make sure to provide info which is requested in the original post, generate a log and PM me the file link (upload first in your cloud storage).
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin