Showing results for 
Search instead for 
Did you mean: 

Armoury Crate does not detect GPU and shows as extreme power saving

Level 7

I have no idea if it is a software error but a few days ago Armory Crate does not detect my graphics card and shows me in the GPU statistics as extreme power savings, I already reset my computer, I used the tool to uninstall the software, I don't have the gpu power options in AC, I have no idea what is happening but it is a stressful situation, I hope to find someone who can clarify my doubts or help me
My laptop is a G513QY
AMD Radeon RX 6800M

Captura de pantalla 2024-05-25 231047.png


Level 7

Armoury Crate while a Unity project is open.Armoury Crate while a Unity project is open.Task Manager with the same Unity project open, showing the GPU is, in fact, working.Task Manager with the same Unity project open, showing the GPU is, in fact, working.

I'm having the same issue! It was working and just yesterday the GPU entered "Extreme Power Saving Mode" (Note that it also says 0% utilization / 0mV, or pretty much dormant). There does not appear to be any option to turn it off. I checked Task Manager and the GPU is indeed working. I tried disabling (and even deleting) the GPU drivers, then re-installed and updated them. I tried checking my computer's system files for corruption and nothing seems amiss. Even if Ultimate Mode is enabled the GPU still reads as Extreme Power Saving Mode. I think this is an issue within Armoury Crate itself. I uninstalled it and reinstalled Armoury Crate to no avail, which leads me to believe that the latest update broke something.

I have an FA617 laptop with an AMD Radeon RX 7600S GPU.

Level 8

Asus ROG Strix G15 G513QY dizüstü bilgisayarım Armoury Crate'teki grafik kartını algılamıyor. Ayrıca, sistem yapılandırma penceresinde ekran yenileme hızı eksik.


Ekran görüntüsü 2024-06-01 194422.png


Ekran görüntüsü 2024-06-01 194620.png


Ekran görüntüsü 2024-06-01 194700.png


Level 7



Same problem here, it say's the GPU is in extreme power saving mode, tho it does show in my adrenaline its there.

Anyone still have the same problem? or any fix?

"Bir hata raporu oluşturdum. Ancak, bunu dikkate alıp almadıklarını bilmiyorum. Yeni güncellemenin yayınlanması Pazartesi günü yaklaştığından, hata raporlarını kabul etmeyi bıraktılar. Önümüzdeki güncellemede düzeltip düzeltmediklerini göreceğiz."

Level 7

I was able to fix this through device manager, and enabling the dgpu, sometimes even igpu doesnt even show up, i used myasus diagnosis to fix igpu and device manager to fix dgpu.


Level 8

This problem is not occurring for the first time. This issue arises with every Armoury Crate update. From now on, I will not purchase products manufactured in collaboration between ASUS and AMD. BIOS issues, graphics card driver issues, USB driver issues, CPU overclocking disappearance issues—since I bought it, I think I've used the laptop without problems for one week. I guess they expect me to throw away the product I bought after two years and buy a new one.

I uninstalled the Adrenalin Software Edition and Armoury Crate software. I tried various methods, such as reverting to version 24.3, but this led to even more issues, such as the disappearance of CPU overclocking in the tuning section. Finally, the solution to my problem was as follows: I installed the Adrenalin Software Edition version 23.11.1 and then installed Armoury Crate using the installer tool. I didn't apply any updates, and this method resolved my issues.

Ekran görüntüsü 2024-06-25 035920.png