cancel
Showing results for 
Search instead for 
Did you mean: 

Armoury crate blue-screen'ing clean installs of Windows 10

PwnSensei
Level 8
As title says.

I've had blue screen and performance issues on my computer,
today I clean-installed windows 10 to sort them out,
right after windows updated I have proceeded with installing armoury crate:

Mouse lags, screen freezes, blue screen. 5, 6, 8 times.
I uninstall armoury crate bit by bit, often being interrupted by blue screens.
Once armoury crate is out of the picture, no more problems.

This is some terrible software.
As a developer myself I am very disgusted by how awful armoury crate's state is,
You should not distribute unstable software and cause trouble for your customers.
You should provide a stable working alternative for controlling motherboard functionality. Perhaps in the bios.

My experience with Asus products can be described as extremely disappointing.
I was supposed to work this morning, not reinstall windows and fight some rogue overflows.
3,736 Views
3 REPLIES 3

cjmnews
Level 9
Agreed on the quality, and lack of actual support.

Look at removing the parts that cause blue screens. Patriot Viper M2 SSD RGB software is the current biggest culprit. Try removing that and see if that helps. You can find it in Settings->Apps.

Hello, after much work and windows re-installs I have Aurmory Crate installed and working but I have several issues and I’m hoping someone can help me solve these annoyances which can result in a BSOD.
Armoury Crate runs fine when I log in with Admin rights. Due to the crashes which have caused me to have to wait days for my Raid to rebuild I have Never tried to run Aurmory Crate with right click run as admin.
The issues appear when my user account logs in. When I thought things were OK in the beginning until one day the user account was prompted to run ArmourySwAgent & ArmourySocketServer which I clicked OK on both. That resulted into a spinning circle which would also blink back to a mouse pointer over and over until BSOD. To be clear with the user account Armoury Crate IS NOT TRYING TO BE RUN…it’s not even on the desktop.
Uninstalls of Aurmory Crate never quite worked well and left parts of Aurmory Crate not working until I did another re-install of Windows.
Also every time a “user� logs out they get a notification:
AcPowerNotification.exe – Application Error
The exception unknown software exception

Ever thing work fine when logged in as Admin no pop ups no errors

Thanks to anyone for help/suggestions

Mack023
Level 9

I can tell you what worked for me, what i did was this killed spooler service.