cancel
Showing results for 
Search instead for 
Did you mean: 

Armoury Crate 5.8.6.0 will not let me log in?

JBBlack
Level 8

 Hello all, 

 For some reason every time I start my PC after updating Armoury Crate it tells me to register my products, Z690 and RTX 4080, so that I can receive support, but they are already registered.

 So I tried to log in and all I get is a message saying the server is abnormal?

Everything else seems to be working okay, lighting effects, info...

Any ideas??

Screenshot 2024-03-04 073636.jpg

ASUS Maximus Z690 Apex ; intel 12900k ; ASUS Strix 4080 OC RTX ; 32G Corsair Vengeance DDR5 4800mhz XMP1 ; Samsung 980 Pro Gen4/Windows 11 Pro ; Creative AE-7 ; 2-2TB Samsung 970- Evo in DIMM.2 ; Dual LG 4k Screens ; EVGA 1300P+
2,147 Views
1 ACCEPTED SOLUTION

Accepted Solutions

MasterC
Community Admin
Community Admin

In the case of log in issues, try going to the ROG website then log out and back in, then try again. 

MasterC_0-1709694660820.png

 

_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

View solution in original post

7 REPLIES 7

archimusic
Level 7

Same happened to me!

No idea at all

MrAgapiGC
Level 13

can please check with a normal website? just to check

 

I can see it but the link on the app take me to another page. can be something internal on the app. I can log perfect. Please check with the wesite. i will send a email. but the time they check it will be later time for me

 

Learn, Play Enjoy!

MrAgapiGC
Level 13

just check again is working but i will report it anyway. just add one my scope2. i will report anyways.

MrAgapiGC_0-1709669620872.png

 

Learn, Play Enjoy!

JBBlack
Level 8

Okay, I finally got it, I had to delete my saved account and re-login.

 It took a few minutes but it worked.

ASUS Maximus Z690 Apex ; intel 12900k ; ASUS Strix 4080 OC RTX ; 32G Corsair Vengeance DDR5 4800mhz XMP1 ; Samsung 980 Pro Gen4/Windows 11 Pro ; Creative AE-7 ; 2-2TB Samsung 970- Evo in DIMM.2 ; Dual LG 4k Screens ; EVGA 1300P+

MasterC
Community Admin
Community Admin

In the case of log in issues, try going to the ROG website then log out and back in, then try again. 

MasterC_0-1709694660820.png

 

_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

Works for me. Thanks!

jmasusrog
Level 7

For me, the solution didn't work

How to delete the saved account in armoury crate app and re-login?