Showing results for 
Search instead for 
Did you mean: 

Armoury Crate "Can't open AsIO3.sys"

Level 8

OS: Windows 10 22H2
BIOS: 2004
Armoury Crate Version:
Virtualization Based Security: Off
ASUSCert Service: Automatic/Running

1. Install Windows 10
2. Install Windows updates and restart
3. Download and install Armoury Crate from the ROG website and restart
4. Download device updates in Armory Crate and restart
5. Download device drivers in Armoury Crate and restart
6. Get updates from the Microsoft Store (Includes Armoury Crate), and restart
7. See error on "Can't open AsIO3.sys!! Failed with error code 5: Access is denied."
8. Open Armoury Crate and sit through install again.
9. Reopen app, and see... nothing. Armoury Crate is a window with no content, or side items.

RGB lights are also off starting at step 7, and I can't use Armoury Crate at all.

Any help would be much appreciated. Thanks in advance.



Hello jasoncollege24

Try using the Armoury Crate uninstall tool and reinstalling.

In the link below select windows 10, click "Show all" in blue, the uninstall tool is the third download.

Armoury Crate - Support (

Once uninstalled, install Armoury Crate version (first download), then go to the update center and update your devices.






Level 8

the version shown there failed. I went to my board's support site, and downloaded that version, and it failed too. At this point, it's just a vicious cycle of restarting and failing the uninstall, but now i'm getting a message from Windows asking me to install AC.

This is the second time in a row I've done a clean install of Windows because of this problem. The first time, I was able to uninstall AC, but was having other issues. This time, it looks like I can't uninstall it.


Are you able to do a system restore to a time when Armoury Crate wasn't installed?

This could save you from having to reinstall windows.



Level 8

Nope. that resulted in a BSOD "CRITICAL_PROCESS_DIED" so now I have to reinstall anyway. I see you suggest version above. The version that I download from my board's support site works perfectly fine. It's literally just the version currently on the MS store that causes me problems.

Would it be better for me to just download the individual drivers and updates from the page, and ignore the armoury crate app? I really don't need the lights. My main focus with the Armoury Crate app is to get all my drivers. Control over the lights is just a bonus, which I can problably achieve with an open source app.


Yes, it's better to get the drivers from the company website.

Here's how I do it....

1) Install windows.

2) Install the chipset driver for your motherboard and any other drivers you need from the ASUS Support Center. - Download Center | Official Support | ASUS Global

3) Update the Graphics driver from Nvidia or AMD whichever you have.

4) Update windows.

5) Install Armoury Crate.

It's a little bit of a pain I know, but hopefully you'll be done in a couple hours max. I'll be waiting to hear from you, if you have any questions about any drivers, feel free to ask.



Level 8

The process below seems to have resolved it. I saw somewhere else that if you download these items in Windows, you need to unblock the zip files in the file properties. Since I downloaded them in Linux and had them on a fat32 partition, That problem didn't exist, and could've been the original cause.

That, and installing everything through armoury crate (previously) are the only things that I did differently this time.

  1. Install Windows 10 (Local account)
  2. Install available drivers from my board's support site, and reboot.
  3. Update NVidia Graphics driver
  4. Update Windows via Windows Update
  5. Update windows via Microsoft Store
  6. Add logged in account
  7. Update from Microsoft store again
  8. Install Armoury Crate, downloaded from my board's support site

Thanks for the help. I don't know how to set this as resolved.


Awesome, great to hear installing in that order worked for you.

No issues to report here,  sounds like we're both good to go !






Level 8

looks like i was wrong. This is not solved. It's happening again. The only real change I made was messing with my sound drivers. Changed them out, then ended up switching them back, all via Device Manager. No drivers were uninstalled, just switched, and switched back to the exact same driver.

I think there is seriously something wrong with the latest version of Armoury Crate, and since it's an app in the Microsoft Store, Windows updates it automatically, so no matter what, if I install this software, it's looking like I'm going to continue to run into this issue. Considering how important this app is, it makes me less inclined to get another ROG board in the future, if it's just going to fail in such a critical way.

Edit: This seems very much like a permissions issue with that driver file, yet the permissions look correct. Also this time, Armoury Crate is still somewhat working. I have access to the tools, news, and user center tabs, but nothing else.

Edit2: The image below is what I see on windows login.



 Thank you for the screenshot.

I don't know if this would have anything to do with it but, I install Armoury Crate from the ASUS Support Center, I don't get anything from the microsoft store for downloads or drivers. 

I researched this and came across a couple things that can cause this particular error.

One is to Check that AsusCertService is running, you can disable and re-enable it.

 Press the Windows + R keys, type in msconfig and click ok, click the Services tab.