Showing results for 
Search instead for 
Did you mean: 

Armoury Crate "Can't open AsIO3.sys"

Level 8

OS: Windows 10 22H2
BIOS: 2004
Armoury Crate Version:
Virtualization Based Security: Off
ASUSCert Service: Automatic/Running

1. Install Windows 10
2. Install Windows updates and restart
3. Download and install Armoury Crate from the ROG website and restart
4. Download device updates in Armory Crate and restart
5. Download device drivers in Armoury Crate and restart
6. Get updates from the Microsoft Store (Includes Armoury Crate), and restart
7. See error on "Can't open AsIO3.sys!! Failed with error code 5: Access is denied."
8. Open Armoury Crate and sit through install again.
9. Reopen app, and see... nothing. Armoury Crate is a window with no content, or side items.

RGB lights are also off starting at step 7, and I can't use Armoury Crate at all.

Any help would be much appreciated. Thanks in advance.


Level 8

I did some of the same research before posting on the forum. That service runs automatically on startup, and virtualization based security is also off (Memory integrity). Hyper-V is also not installed.

I mentioned these items in the first post. Sorry you missed that. 🙂


Ok, no point in making suggestions you already tried.

Some say lightening up on the windows user account control will get it to work, but you shouldn't have to do that.  There might have been something about user account control during the Armoury Crate install, I click yes or agree to whatever it says. 

I'm using windows 11 and don't have to fool with the memory integrity either. 

Does logging into Armoury Crate have any effect?

I don't know if this would help but, what would you think about giving windows 11 a try? It's a free upgrade and is what I'm using. I have quite a few devices and I'm not having any problems.

Armoury Crate Devices.png




Level 8

I was using Windows 11 before this hardware upgrade. (board, and ram) Don't much like it. I did allow UAC during install. This instance of the problem happened after all was installed. Everything was working fine this time, until I swapped my sound driver, then swapped it back to what it was originally.

The version of Armoury Crate on the website is the version listed in the post that is pinned at the top of this forum. The one that gets downloaded from the Microsoft Store during it's automatic updates is the version listed in my original post.

I'm curious. Are you running version


Yes, Armoury Crate updated to a week or so ago, click the picture to make it bigger.

I'm using the ROG Delta S Animate headset, there are no sound drivers to install, they install automatically with Armoury Crate.

What headset/speakers are you using?


AC Update.png



Level 8

So I found something that might work. I've tried a lot of other troubleshooting steps during this install that only made the problem worse. I'm going to reinstall Windows 10, and follow the steps to fix service dependencies, as shown in this reddit post because it looks promising.

I'll either edit this post, or reply again with the results.


Well, you could reinstall windows. I might suggest to try using the Armoury Crate uninstall tool and reinstalling Armoury Crate. If this fixes it, it would save you from reinstalling windows. The instructions are in my first post, if it doesn't work, you could try a system restore to when windows was installed.

Just trying to save you from reinstalling windows, unless of course you want to do a fresh install.

I do find it strange that trying a different sound driver caused the AsIO3.sys error. 






Here's what I tried:

  1. Install Windows 10 (Logged in account)
  2. Update Windows via Windows Update
  3. Update Microsoft Store Apps
  4. Update nvidia driver
  5. disable fast startup (For Linux Dual-boot)
  6. Install or run items in the screen shot below in the order they appear.
  7. Reboot after each one, except 08 (which had the access denied error during install, and 09 runs the service dependency commands in an elevated command prompt)
  8. reboot again, and check for windows, and store updates
  9. Run armoury Crate, and see a second installation that is MUCH quicker.


This worked fine for a couple of reboots, but then the lights stopped working, Armoury Crate is mostly blank. (There are no more access denied errors)

I think I'll just uninstall Armoury Crate (or reinstall Windows 1 more time to remove stuff the uninstall tool doesn't), and rely on 3rd party apps to handle drivers, and lights. This issue is holding up productivity, because I need this Windows install working and stable.

Your help has been very much appreciated, and I thank you for it. I feel like I wasted your time, but I do hope this post helps someone to find a solution, or the devs to fix the issue.


You're welcome, 

I'll comment on the files you listed.

1) Chipset - I Install this from the ASUS Support Center.

2) MEI driver - You can install this from the ASUS Support Center or updating the bios will update the MEI driver.

3) Audio - As mentioned, I don't need to install any sound drivers. If you're using the 3.5mm jacks, then you'll want the Realtek audio driver with Sonic Studio 3.

4) Bluetooth - I'm pretty sure windows installs a bluetooth driver, it works fine so I don't install any bluetooth driver.

5) LAN - I'm using Wifi only, I don't install the LAN driver.

6) Wifi - Windows installs a Wifi driver and works fine, I don't install any Wifi drivers.

7) Intel Rapid Storage Technology - I don't install this.






Yup. all of those files that were downloaded i got straight from the asus support site, specific to my board. I have them saved on a separate partition.

I am indeed using 3.5mm jacks, and I love the sound quality! I install 4-6 to keep them at the latest. 7, i grab, because I have 2 M.2 drives, and several laptop SSDs installed.

I would name the 3rd party apps that I'll be using, but I've always seen that as bad form to "advertise" 3rd party stuff, unless you think it's relevant to mention?