Showing results for 
Search instead for 
Did you mean: 

Armoury Crate EMPTY SCREEN / Not Responding

Level 8
I downloaded the app from the ASUS website and installed it.

I've done this multiple times using the Armoury Crate Uninstall Tool tool with the same results.

Does anyone have any idea(s)?


does not have this soft.

Level 7

This happened to me after I totally cleared it out. I had to just kind of wait, the thing takes forever to right itself. Leave it on, and eventually it shut down, I reopened and it finally presented itself. Can try shutting on and off other programs. But this thing is the worst software known to man. Leaves drivers you can't delete without unlockers in System32 like a root kit. Horrible stuff. But I do like the Asus mice sadly. But you can use OpenRGB to control the color, which automatically on Gladius III is awful and ridiculous. Then you can delete the software you don't need.

Level 8

Guys Same problem here . Any solution ?

Check if you have any OSD software like Afterburner or RivaTuner active. If so, shut them down and it will load/update. Mine worked that way.

its closed should I uninstall those two ?

Hmm I don't think so, I just shut them down and it loaded.

Level 8

Same thing, empty screen despite everything I've done.
I closed Afterburner etc, NOOOOTHIIIIIIING.

This software is driving me crazy

Did you disabled armoury crate installation from bios ?

Wish I could help you more. Mine worked with the AB shutdown. It works fine with it on now by the way. Try closing