cancel
Showing results for 
Search instead for 
Did you mean: 

Armory Creator 5.7.3.0 not loading spatha Error 2005

OwerlordX
Level 8

I cant change my mouse settings after the update, tried to reinstall it but didnt help. The app just loading it for a few minutes then error 2005 appears.

291 Views
6 REPLIES 6

Nate152
Moderator

Hello 0werlordX

Do you get the 2005 error with both 2.4GHz wireless mode and wired mode?

Try with the cable in wired mode, make sure the cable is connected directly to a pc usb port.

On the bottom of the ROG Spatha, set the wireless switch to off.

Then try opening your ROG Spatha in Armoury Crate, wait for the spinning red circle, it should load the buttons page.

I'm using the ROG Spatha X.

ROG Spatha X.png

 

 

I tried with both wireless and wired mode. The cable connected directly to the motherboard. I have got the spatha, not the spatha x if that helps.

Nate152
Moderator

Try uninstalling Armoury Crate again from the start menu, this will activate the Armoury Crate uninstall tool. Then, install Armoury Crate version 3.2.9.1 and update your ROG Spatha at the update center.

Armoury Crate - Support (asus.com)

This should fix the 2005 error.

uninstall.png

I tried it and did everything as you told but it still gives me the error.

Nate152
Moderator

Thank you, sorry that didn't work.

I came across a thread where someone lists what they did to solve the 2005 error.

See the second post on page 3.

Error 2005 - Help please - Page 3 - Republic of Gamers Forum - 888942 (asus.com)

 

 

 

 

 

 

 

 

A managed to make it work by installing the old armoury app (not armoury crate). It works in the old armoury.