Showing results for 
Search instead for 
Did you mean: 

Armory Crate Tools unknown error with the content. Please try to restart Armory Crate.

Level 9

Issue is the topic itself. I have tried every way I can google to fix this issue aside from a fresh OS install. Which I vehemently refuse to do. Is there any way to actually make that tab work? And what does it even do? All I can find is subjects going back at least a year or more with the same issue and no solution. Just the usual "uninstall the legacy Aura Sync." Kinda can't since I just upgraded to this motherboard approximately two months ago, so the odds of me having the old version is slim. I've only done the most recent installers for Armory Crate. Only other program I could possibly think of is the app for Logitech hardware I 'have' to use to use my g600 series mouse macros, and my Artemis Spectrum headset. Since it can also control the L.E.D.s in the headset and mouse. But that seems like reach honestly. Read something about Malwarebytes possibly not liking the Armory Crate software but couldn't find anything conclusive there.

To conclude; I've turned off fastboot, system hibernation is also off, I've done an uninstall with the official software, an install with the official installer, have no other RGB accessories that even interface to this, and still don't know why a tab that seems like it would be something mildly important(since it has a section called drivers in it) won't work. 


Level 9

Oh, hey I now know one utility in the tools section from clicking on my B650E-F motherboard  in the app. AI powered mic noise cancellation. Still says the same error when directed to the Tools tab though.

Level 9

If a log of the application or anything is needed to help fix this I can make one. Made one before posting this thread to try to read it myself but it wasn't a format I can actually read with even notepad++ so that idea of troubleshooting myself was DOA. I saw some mention of the Microsoft Visual from 3 specific years had conflicts with the program? Yet can't find any confirmation or anything for that claim.

Level 7

I don't understand why this dumb application doesn't work.