Showing results for 
Search instead for 
Did you mean: 

Armory Crate+ Corsair ICUE problem after BIOS update

Level 7
I'm not sure if this is an Asus or Corsair issue but I updated my ROG Strix B450-F Gaming to BIOS 4204 and it broke something in the RGB department.

My Strix graphics card and peripherals work normal in ICUE but I can't control my mobo in there anymore. It is detected but changes made in ICUE software have no effect. Aura Sync in Armory Crate app work like normal. I have reinstalled both applications and I can't make motherboard controls work neither for the ROG logo or the case connected to the RGB header. Any idea?

Level 13
Problem solved. ASUS core keyboard and spatha mouse pulled, PG35VQ on internal lighting. Using last 3 series of IQue. Last Aura (NOT CRATE) installed without ever launching it and the plug-in from the IQue forum. Now I can at least do the MOBO. Liking the Corsair K100 keyboard a lot more as well as the dark core RGB pro mouse. Sitting on an M800 RGB mouse pad. Add one more freaking ASUS product to the mix and it takes a bit old crap. So long ASUS expensive a$$ keyboard and mouse. Should be simple and seamless. I could get it to pull in GPU cards but I’m not using what on the card. I have heat killer blocks with addressable RGB that with an adapter plugs right into a Corsair addressable controller and works perfectly. Like I want to add more problems? I’d love to get the monitor working and may try crate one more time without everything else if I get bored and have hours to get rid of all traces of it when it fails. May say screw it and just turn those off and order the Corsair kit that mounts to back of monitor.*

After installing iCue 4 and doing a clean reinstall Armory crate the mobo and gfx card are back in sync finally.

Looks like the latest update to Armory Crate has broken the ICUE sync to the motherboard again....

adtither wrote:
Looks like the latest update to Armory Crate has broken the ICUE sync to the motherboard again....

I noticed that too. I gave up on trying to use iCUE to control the lighting. Very frustrating Asus and Corsair cannot work more closely together on this.

adtither wrote:
Looks like the latest update to Armory Crate has broken the ICUE sync to the motherboard again....

Is that the update?

Hey guys,

I am asking if all of you resolved your issues concerning iCue and Asus (armoury crate/aura + Ai suite).
So far, I've always been using both and there were no issues of compatibility or so, but, since a week or so, I can not even launch iCue anymore, the main window of iCue is poping up, then crashing after 2 or 3 seconds. Thanks god, my previous settings are saved somehow with Corsair's services running in the background, thus, the pump and fans are turning still, with the lightning profile i had assigned when iCue was working. So, the pump is settled on max rpm and fans have a curve that i've settled as well on my H150i Elite capelix pro.

I was also able to manage my mobo on iCue before it became to crash, I deactivated all the leds of the motherboards, since i prefer to play with them on armoury crate, using the "intelligent" preset (colors changing according to the CPU temperature). I've tried to uninstall iCue several times, did not work yet.

I've now to try to uinstall armoury crate and/or Asus Ai suite (that might be the issue actually since it began to bug more or less when I installed Ai suite, but I need that software for several reasons : overclocking and testing, case fan control, etc ...).

So, I would be glad to hear your feedbacks and if, for all of you that had that issue, resolved it and how.

Thanks !

Problem solved it seems, had to uninstall cleanly every software one by one (using armoury crate and Ai suite uinstall tools), Revo uninstaller in "Forced MSI uinstall" for iCue, than installing iCue first, then armoury crate, and finally Ai suite.
iCue does recognize my Asus rog formula XII and is able to change the Aura devices.