Showing results for 
Search instead for 
Did you mean: 

Armory Crate 5.6.3 Update affecting Ryujin II Display

Level 8

Earlier I updated to AC 5.6.3, I didn't want to but, of course, one is forced to if you want to change a color or setting. Since installing the Armory Crate & the  3 additional updates that were required: HAL Application, Motherboard update (Asus ROG Strix Gaming Wifi II), & Ryjuin II update my Ryujin II will no longer display the CPU frequency on the LCD display. The Armory Crate application is displaying the correct frequency on the dashboard so I know it's able to monitor the frequency, however, it will not output the data to the Ryujin II display. Oddly it's the only piece of data that will not show on the LCD display. 

Has anyone else had similar issues?  I've tried uninstalling (via the tool) and re-installing but that hasn't resolved the issue. 


12.jpgScreenshot 2023-05-25 231453.jpgScreenshot 2023-05-25 231642.jpg


Level 7

I had the same issue. My solution was to install the full package installer. That installer will have you select each ROG component manually, but the Ryujin will work again. Just make sure not to update the Armoury Crate app, the Ryujin will disappear again.

when running the full package installer i don't even see Ryujin II as a component to manually select

The new version now works with no issues. No need for the full version at this time.  Maybe a glitch in the previous version.

What do you mean by new version? Can you please be more specific?  I tried running both the lite version and full package installer multiple times and got the same issue with both. I really don’t want to reinstall windows and feel like if I try that the issue still won’t be resolved. 


I apologize for not being specific.  I uninstalled AC completely then installed the new Armoury Crate & Aura Creator Installer Version  Everything has detected and work fine now and I have a whole shlew of ROG Strix in my computer;  Keyboard, mouse, motherboard, Ryujin II, monitors, graphics card and headphones all being controlled by AC.

Thanks for your reply.  I've tried the following and have still been unsuccessful in getting my motherboard or Ryujin II to detect..

  • Uninstalled AC using both the Asus uninstaller and Revo uninstaller
  • Reinstalled AC using both the lite (online) and fiull (offline) package versions. 
  • Tried using a different internal USB port on my motherboard for the Ryujin. Still not detecting in AC.
  • Rolled back Nvidia drivers.  I think the issue might have started after the last nvidia update but not 100% sure.
  • Updated motherboard BIOs and chipset drivers to the latest version 

Still can't access my Asus devices in AC at all.  very frustrating because the AIO pump speed is dependent on AC and I am unable to adjust it back down to the where I had it previously.  The pump now makes a horrible whining sound constantly with its current default setting.

When I reinstalled AC I did not choose the option to install Aura Creator or Virtual Pet.  It is unlikely but maybe these need to be installed in order to get the Ryujin II to detect?