cancel
Showing results for 
Search instead for 
Did you mean: 

Sqaure-like artifacts on stock clock speeds? Asus 7970 Matrix Plat.

ManSlayer
Level 7
Been having some problems with my newly purchased 7970 matrix. I keep getting some square-like artifacts on stock clock speeds and was wondering if anyone has any suggestions before I end up RMA'ing it. Below are a few screen shots I took showing what i mean by square-like artifacts.

15876
15877
15878

As you can see, they can get quite annoying and im not sure it thats actually my GPU thats causing that or somthing else.
I've tried using the 12.10 drivers as well as the 12.11 drivers but the artifacts still appear.

System Specs:
CPU: i5-3570k (@3.4GHz)
Mobo: MSI Z77A-GD65
GPU: Asus 7970 Matrix Platinum
RAM: Corsair Vengeance 8GB (2x4GB)
SSD: SanDisk 240GB
PSU: Kingwin 1000Watt

Any help would be appreciated!

Thanks
188,291 Views
143 REPLIES 143

saviourself
Level 7
Identical issue on my brand new 7970 Matrix Plat and similarly I'm thinking of RMA'ing it, particularly when ya factor in the driver issues I've had with WoW...

What I've found alleviates it somewhat is to turn the fan duty cycle up to 100% on both fans, but it doesn't eliminate it. Mind you, on stock fan speed in my air conditioned room, the GPU tops out at about 65 degrees which shouldn't be stressful in the slightest (at 100% on both, it sits at about 50, so I gotta give Asus kudos, that's one hell of a cooling system).

This is at stock clocks. I've been unable to even put a mild OC on the card (50 Mhz) without artifacts showing up immediately. Kinda disappointed tbh...
Intel Core i7 3820 (Corsair H80i cooler)
ASUS Rampage IV Formula
G.Skill Ripjaws Z F3-17000CL9Q-16GBZH 16GB
ASUS Radeon HD7970 Matrix Platinum
OCZ Vertex 3 SSD (128 gig), 5 terabytes of assorted disc
Corsair Obsidian 650D Case
Corsair 1000w PSU

Radsy
Level 7
yah i get this artifacts as well @ stock speeds i had a play on w.o.t to day for about 20mins and got this when playing sometimes you cant see anything so then i restarted the game and then it seems to have gone, well till the next time ...
1590616164

i've had the same issues to at stock. It goes away when i alt-tab out. Appears randomly at times which is disappointing. Sometimes doesn't happen when overclocked to 1250. So I'm not entirely sure what is going on.

Thomoe
Level 7
I have had 2 matrix.. 1 platinium and one "normal matrix" both did this my platinium made that Sqaure-like artifacts. The other one ****ed up the sky big time in BF3 after 1 hour of gaming.. And that is in stock clock... BOTH CARD HAVE BIN RETURNED... This is so bad, This should be the best single card for gaming in 2560x1440 and i am so dissapointed..

WHAT TO DO.... tried a GTX670 4 GB and it is just not the same, i realy like the AMD 7000 series, but the matrix sucks.... What to try next ?

Shikatsu
Level 7
I've also been experiencing artifacts all over the place. It ranges from games like Far Cry 3 and Dota 2 to even Netflix. I'm at stock and temperatures never go over 50 degrees. I'm most likely going to RMA this card. Pretty disappointed with it.

Thomas
Level 10
Please install GPU Tweak and attempt to update the VBIOS, if that does not resolve the issue then please RMA the card.
Thomas Jenner
Asus UK

Thomas@Asus wrote:
Please install GPU Tweak and attempt to update the VBIOS, if that does not resolve the issue then please RMA the card.


its up to date the VBIOS, so its time i feel to rma this sh*** , starting to get ticked off with this nothing but problems if its not cards its driver issues.. what i like to know it how did this card make it out of the Warehouse if it has problems, dont go much on ur testings

Thomas@Asus wrote:
Please install GPU Tweak and attempt to update the VBIOS, if that does not resolve the issue then please RMA the card.


Well, well...Mr. Thomas, why don't just tell the truth to the people? Where is Your advice on ASUS ARES II thread? What about us? Nice...i payed 1400e for what? And now ASUS do not doing anything to correct the problem - maybe 'cause the it's impossible to fix?

TO ALL OF YOU GUYS: YOU ARE NOT ALONE WITH YOUR PROBLEMS, LOOK AT THIS:

http://rog.asus.com/forum/showthread.php?30199-Asus-ares-2&highlight=ares

PoTski
Level 7
Have the same issue. Glad to find this thread.

I even have this when im watching youtube. Get this in LoL too. dont think that game require much, but still.16154



im on 2x 3008wfp and 2x 22" Dell.
30" running with DP and 22" dell on DVI

windows 8 x64 ent.
amd: 13.1 driver