cancel
Showing results for 
Search instead for 
Did you mean: 

Radeon HD 7970 DC2 TOP - Issues

stitch
Level 9
Hi Everyone,

I just wanted to post my experiences with my first iteration of this card just so that others were aware of some signs that they may have a defective card.

Windows 8:
Yes, I know this card doesn't even have preview drivers yet, but oddly it worked best under Windows 8. The issues I encountered were limited to random BSOD after the system sat idle for long periods of time (even with power saving features turned off like turning of the monitors and sleep). It seemed to run games just fine. The only odd-ball thing I noticed off the hop was the factory set clock when I opened up Overdrive was the 3D clock was set to 600 MHz. Even after that things were okay except for the random BSOD.

Windows 7:
This is where things went south fast. Running a game like Battlefield 3 or Mass Effect 3 at 1 GHz (factory overclock) resulted in a crash (3 screens, 1 different colour per screen) as soon as the GPU's 3D clock kicked in and the game was going to go full screen. I checked voltages, I checked card temperatures, everything seemed okay (except for the well documented VRM issue) with the card. My system voltages are stable, temperatures are nice and cool (my CPU generally only hits 40c if it is really hot in the room.) I disconnected devices, tried with only one monitor, no banana. So I downclocked the GPU to 925 MHz. Battlefield 3 now loads as does Mass Effect 3. Battlefield 3 does crash after 15-20 minutes with a black screen crash, but I was expecting that to no doubt be another issue un-related to the card itself.

So what am I doing? I'm taking it back to the place of purchase and praying that they have a newer revision of the card with the VRM cutout on the backplate and will see if the store will test it before I take it home.
Windows 11 Pro | ASUS ROG STRIX X670E-E GAMING WIFI | AMD Ryzen 7800X3D | 32GB Corsair Vengeance RGB DDR5 6400 | ASUS ROG STRIX GeForce RTX 4070 TI
150,242 Views
219 REPLIES 219

X-ROG
Level 15
What is your exact system spec?

ssmb_92
Level 7
Yeah BF3 can be a mad pain, just reading that section of your complaint. I played it all night last night with no probs, CPU up to 4.5ghz and 7970 at standard setting. But all day today, BSODs and hangs.

Hi Spoony, haven't been around for a while mate and now i want to use my computer i can't without crashing again. So here i am again. Complaining. One of my 7970s is dead now and the other won't come out of x8 mode. Also i am running the 1.02 board so no idea what the **** anymore.

Anyway, running standard settings now, no OC on anything, still BSODs and error 5A during POST but computer boots. 12.8 catalyst changes frick all, still keep having dxgmm1.sys crashes, even on fresh install of windows.

My conclusion: Don't buy ASUS cos only half the users come out wih working rigs. The rest suffer miserably and waste their time with RMAing the s*** to no avail and at their own expense and time. Can ASUS truly find this acceptable? Should be a total recall if you ask me, had to buy a new processor (a 3960X at that FM) today now i know the standard setting in BIOS for the 3960x kills it by over voltage, which i ran for a couple weeks at the start.

Know i sound like a raving lunatic all over the place, but i feel like one for going ASUS now anyway so there. Just want it to work as specified you know........

Meowws.... Lets go and jump off a cliff together, were not getting anywhere my friend. LMAO......

UPDATE: I updated my signature to go with my rigs' current state. LMFAO.....
My Rig:
Rampage 4 Extreme BF3/Dead 3960X thanks 2 RIVE/16GB (4x4GB) G.Skill RipjawsZ CL9 PC19200 2400Mhz/ASUS HD7970 DCU2T No longer Xfired - 1 card dead n never really worked/Threw away my Phoebus/Thermaltake Toughpower 1500W PSU/480GB Intel 520 Series SSD/2TB WD Black Caviar HDD -- All in Thermaltake Level 10 GT LCS (BigWater 850GT LCS) Chassis with all the bells and whistles. Peripherals: Vulcan ANC, Logitech G-19 K/Brd, Logitech G700 Mouse.

Spoony
Level 8
ive stuck with 12.7 for a starter. 2nd thing is i MANUALY active the game profile im going to play, auto doesnt do ****, to which thats not a driver fault as it does with the 6970 but the 7970DCU2 TOP card will not change its ways from the clocks or settings or anytbhing else.

not though i was given a 7970DCU2TOP card so i have crossfire and no it works better, BUT ONLY if i dont overclock my CPU (3930K) passed 4.0Ghz, anything more its goes ape ****, and my ram is ripjaw z 2133mhz 32gb and all is well now.

any questions on other tweeks mail me direct as usual.

BUT last note.

MarshallR@ASUS. dude dont waste time asking spec's thats not the issues unless daft overclockign is being done, ive gone through so many drivers and set up's with other boards CPU's GPU's its unreal and every time i plug in your top 7970 it does nuts, ALSO it still wont work with more than 3 monitors and dont even think about says its monitors its isnt, ive been though all dvi all hdmi all dp you name it ive tried it and still is 3 max.

im pissed im unhappy i cant change my cards since ive moved countries and by the end of this year i can tell you this now i will no more about your products than you will and that is FACT since ive used 7 asus boards (4 other makes. intel or AMD doesnt matter, 9 diff sets of rams and size kits and speeds 6 diff SSD or HDD and 5 diff kinds of GPU's not including your 7970 top card.

all other cards work but your 7970 top cards dont and that is FACT my friend. oh and y9our telephone support is BULL and you need to sort it ASAP and also get a team to ACTUALLY do the RMA's except turn it on see it working on a none load desktop and then send the same thing back and say it fine.

WHICH IT ISNT !

ssmb_92
Level 7
Couldn't of said it better myself. Except i would of swore more...

On a brighter note, how was the move Spoony? hope you are fairing well, disregarding the ASUS product issues of course lol, i am completely bald myself, first time i cut my hair WITH MY OWN BARE HANDS (thanks ASUS)

Persistant Perfection eh?
My Rig:
Rampage 4 Extreme BF3/Dead 3960X thanks 2 RIVE/16GB (4x4GB) G.Skill RipjawsZ CL9 PC19200 2400Mhz/ASUS HD7970 DCU2T No longer Xfired - 1 card dead n never really worked/Threw away my Phoebus/Thermaltake Toughpower 1500W PSU/480GB Intel 520 Series SSD/2TB WD Black Caviar HDD -- All in Thermaltake Level 10 GT LCS (BigWater 850GT LCS) Chassis with all the bells and whistles. Peripherals: Vulcan ANC, Logitech G-19 K/Brd, Logitech G700 Mouse.

Spoony
Level 8
im all good bro, move was good, off toa shooting comp this week gonna take the GPU's and hit them at 750m or 1500m, havent decided yet 😛

I'd like to fill em with C4 and send em back to ASUS but they'd never pass customs lmao, i might go to a shooting comp too then rofl...

Definitely clear to me now that the s*** is never gonna get any better, i'm building a new rig now with EVGA board n cards. I think it's best to keep away from ASUS now but im'a hang around these forums n see if anything changes, i have seen miracles done before lol.
My Rig:
Rampage 4 Extreme BF3/Dead 3960X thanks 2 RIVE/16GB (4x4GB) G.Skill RipjawsZ CL9 PC19200 2400Mhz/ASUS HD7970 DCU2T No longer Xfired - 1 card dead n never really worked/Threw away my Phoebus/Thermaltake Toughpower 1500W PSU/480GB Intel 520 Series SSD/2TB WD Black Caviar HDD -- All in Thermaltake Level 10 GT LCS (BigWater 850GT LCS) Chassis with all the bells and whistles. Peripherals: Vulcan ANC, Logitech G-19 K/Brd, Logitech G700 Mouse.

I think I may have solved the problem, or at least 99% of my problems. I was having all of the issues that everyone else was having, the black screen with game audio, a myriad of different 'stripe' lockups and just plain black screen crashes. What ended up solving the problem for me is I updated to Catalyst 12.8. Then I increased the core/memory idle speeds.

Here is the procedure doing it if anyone is interested:

Open Catalyst Control Center


Click Presets.

Click Add preset.

Give a name to the preset (such as Speedy and note it) and save.

Now go to %USERPROFILE%\AppData\Local\ATI\ACE\Profiles\ (AppData folder is hidden. You can access it by going to 'Run' and typing in "%appdata%.).

In Profiles folder, you will see a file called Speedy.xml. This file you have just created.

Open Speedy.xml with notepad.

In this file there is a line

name="CoreClockTarget....."
(xxx00 is your idle-state core clock. Make it 40000)

and another line

name="MemoryClockTarget....."
(yyy00 is your idle-state memory clock. Make it 90000)

Change only the Want_0 values. These are the idle-state clocks.

Now find the line that says "OverclockEnabledProperty" value="True" /> Change "True" to "False"

Save the file with the changes you have made.

Now go back to Catalyst Control Center.

Select the Preset called Speedy and then put a checkmark in the box next to Enable Graphics OverDrive.

Click Apply at the bottom of the Catalyst Control Center window.

Now you can see the new increased idle-state core/memory clock speeds.

Now try to give your card a good TDR if you can.

If your issue is resolved, then you may back off little by little on idle core/memory clock speeds until you find your system's lowest values, just to save energy and help GreenPeace act. If it is not resolved, good luck.
Intel i5 3570k @ 4.2 GHz
MSi Z77A-G45 Motherboard
16GB Gskill Ripjaw 1600 RAM
ATI 7970 Directcu II
OCZ ZT 650W
CM STORM Scout

ssmb_92
Level 7
Inspiring Innovation. Persistent Perfection..........

I think i have a case for false advertising here, maybe i can make a few bucks or at least have their slogan wiped. Lets here some ideas of what they could change too?

I'm think Inebriated Innovators. ???????. Someone think of the next line LMAO X)

BTW thanks ASUS for the RIVE that killed my 3960x on stock settings. Auto settings for VCCSA and VTT were 1.35v and 1.4v respectively. Killed the CPU on it's own base setting, what a farce and yes i know it was the board cos my OC's were to guidelines and many others run at the same specs just fine. On different boards and the same.

EDIT/NOTE: It will be avenged.
My Rig:
Rampage 4 Extreme BF3/Dead 3960X thanks 2 RIVE/16GB (4x4GB) G.Skill RipjawsZ CL9 PC19200 2400Mhz/ASUS HD7970 DCU2T No longer Xfired - 1 card dead n never really worked/Threw away my Phoebus/Thermaltake Toughpower 1500W PSU/480GB Intel 520 Series SSD/2TB WD Black Caviar HDD -- All in Thermaltake Level 10 GT LCS (BigWater 850GT LCS) Chassis with all the bells and whistles. Peripherals: Vulcan ANC, Logitech G-19 K/Brd, Logitech G700 Mouse.

ssmb_92 wrote:
Inspiring Innovation. Persistent Perfection..........

I think i have a case for false advertising here, maybe i can make a few bucks or at least have their slogan wiped. Lets here some ideas of what they could change too?

I'm think Inebriated Innovators. ???????. Someone think of the next line LMAO X)

BTW thanks ASUS for the RIVE that killed my 3960x on stock settings. Auto settings for VCCSA and VTT were 1.35v and 1.4v respectively. Killed the CPU on it's own base setting, what a farce and yes i know it was the board cos my OC's were to guidelines and many others run at the same specs just fine. On different boards and the same.

EDIT/NOTE: It will be avenged.

Are you running memory speed at 2400Mhz by XMP?

HK-47
Level 10
I am having the same issues running 3x1 eyefinity on trififire MSI reference cards.

GHZ Edtion Bios:
I am getting screen freeze sometimes with sound loop/buzzing in eyefinity.

Factory Bios:
Black Screen, with fans @ 100%, sometimes with sound loop/buzzing in eyefinity and single screen.


If you read around the other forums lots of people are having all kinds of issues with the 7xxx series cards!
-Desktop-
Asus Crosshair VIII Dark Hero / AMD 5800x / 32GB Corsair Dominator Platinum RBG (CMT32GX4M4C3600C18) @ 3800 /2x Sabrent 1TB Rocket NVMe 4.0 (Raid 0)/ 1x Samsung 860 Evo SSD / Corsair AX1200 PSU / ASUS Strix Helios Case / Corsair HydroX Custom Loop D5, CX7, XG7 420+280 Rad/ Asus Strix 3090 / Asus PG35VQ Ultrawide Monitor / Corsair Commander PRO 3x ql120, 4x ql140 fans / Edifier 1850DB Speakers + T5 Sub /
Asus Theta 7.1 Headset