cancel
Showing results for 
Search instead for 
Did you mean: 

Radeon HD 7970 DC2 TOP - Issues

stitch
Level 9
Hi Everyone,

I just wanted to post my experiences with my first iteration of this card just so that others were aware of some signs that they may have a defective card.

Windows 8:
Yes, I know this card doesn't even have preview drivers yet, but oddly it worked best under Windows 8. The issues I encountered were limited to random BSOD after the system sat idle for long periods of time (even with power saving features turned off like turning of the monitors and sleep). It seemed to run games just fine. The only odd-ball thing I noticed off the hop was the factory set clock when I opened up Overdrive was the 3D clock was set to 600 MHz. Even after that things were okay except for the random BSOD.

Windows 7:
This is where things went south fast. Running a game like Battlefield 3 or Mass Effect 3 at 1 GHz (factory overclock) resulted in a crash (3 screens, 1 different colour per screen) as soon as the GPU's 3D clock kicked in and the game was going to go full screen. I checked voltages, I checked card temperatures, everything seemed okay (except for the well documented VRM issue) with the card. My system voltages are stable, temperatures are nice and cool (my CPU generally only hits 40c if it is really hot in the room.) I disconnected devices, tried with only one monitor, no banana. So I downclocked the GPU to 925 MHz. Battlefield 3 now loads as does Mass Effect 3. Battlefield 3 does crash after 15-20 minutes with a black screen crash, but I was expecting that to no doubt be another issue un-related to the card itself.

So what am I doing? I'm taking it back to the place of purchase and praying that they have a newer revision of the card with the VRM cutout on the backplate and will see if the store will test it before I take it home.
Windows 11 Pro | ASUS ROG STRIX X670E-E GAMING WIFI | AMD Ryzen 7800X3D | 32GB Corsair Vengeance RGB DDR5 6400 | ASUS ROG STRIX GeForce RTX 4070 TI
468 Views
219 REPLIES 219

Tennobanzai
Level 7
I had the idea of using the non-T Bios on my DC2 Top. Anyone think this will help me at all? I'm honestly at the point of frustration where I just want my GPU to run without crashing. I'd rather have a reliable reference clock of 925mhz 7970 then a huge paper weight
ASUS P8P67 WS Revolution | Core i7 2600k | G.Skill 4GB 1600Mhz 6-8-6 | ASUS GTX 580 | Physx GTS 450 | Intel 40GB SSD + Samsung 2TB F4 | ASUS Essense STX | Corsair HX 750W | Swiftech Apogee XT | Silverstone TJ07 |

ASUS P8H67-i Deluxe | Core i7 2600k | G.Skill 4GB 1333Mhz | ASUS GTX 560 Ti | Samsung 2TB F4 | Silverstone SG05

lenehan
Level 10
It could be a bad card in my opinion. Being using the card for awhile. I have no issue. Sending it back for RMA. Cheers.
Change is the law of life. And those who look only to the past or present are certain to miss the future.

Spoony
Level 8
99% Of these TOP cards are not working and rubbish, but Asus wont help you and they will just send you your old one back, and thats a garrentee.

lenehan
Level 10
I am using Asus and but not bios to them. There are only 2 maker I will always recommend to user. Asus is one of them. Not sure about others but at where I located, Asus distributor may not be one I would like to liase with (matter of fact I rank them the 2nd worst). Having said that, whenevever I RMA my board or gfx card will always retrun a new working set.
Change is the law of life. And those who look only to the past or present are certain to miss the future.

still anyone found a solution crashing problem :(.my voltage still running 1113 and i cant up any tweak programs

I am very mad...... 😞

start btf3 bam crashed...
using antianalyse in TDU2 bam crash....
flc(gta) crash afther 10 min.... (bad ported but still)
playing the old **** for testing (gta san/mta) 2 min bam crash..


The only game that seems to work is: mine cra"p" (java)
(tested)

I even use mobo and GPU from as(u)s.

Ive sent this card back to the store and this is what theyve emailed me

"Hey,

We have just completed further testing for you and we have been unable to fault this item. The tests we preformed were:

Installed on updated test bench and ran same tests as in previous tests with upgraded parts.

Tested on: Intel Core i7 3930K, Asrock X79-Extreme4-M, 16 GB Corsair Vengeance CMZ1600 (4x4GB), Antec HCG-900 900 Watt PSU, WIndows 7 64Bit

- Installed card in system - POST ok
- Loaded Windows - no faults during heaven3D and Furmark (over an hour each)
- Repeated testing after a 20 min shutdown
- Fault could not be replicated"

So far they only tested 3d software and not bf3.
Ive told them to forward this card to their distributor.
I hope they not gonna send me back the same card again.

AH the on going problem of the 7970 DCU 2 TOP card. you got to love it and the fact nobody at asus will lift a finger.

they can never replicate you issue mate, its fact, they wont and dont have a copy of BF3 nor will they test it that way, they bench it and thats about it n send it back to you saying its fine.

the card is a waste of money n asus should offer us all a replacement swap and not a we post ours they post one back **** i mean handed over at the time of we give ours they give there, ive heard no issues with any other branded 7970 thats like this top card, its 1 of 3 things that makes it shut down or BSOD

clock speeds dont work if there at high so need to down clock yoru card 925/1250 and mines stable but thats slower than the stock card 7970 so i want my money difference back.

bios is a sack of ****e and is a major issue n needs updating but there are none our there that work or can update too.

6 ports at back are a LIE it wont work on anything above 3 screens even though it says on the box is should work with 6. i have a limitless supply of diff monitors and configs for them so its bull that asus say use all 1 kind cos ive dont that and all DP or DVI with active adapters and all that jazz.

card was broke from day one

fumoffu1089
Level 7
OK so I got my card back today. still the same issues. after 1 and a half month. Crashed in MOH and BF3.
I have upgraded my PSU to corsair 1200 gold + 16gb dominator platinum ram. And now im currently testing it in my other computer.
Asrock Z77 Extreme 6. i5 3750 and it seems to run MOH ok with some random crashes. currently updating BF3 on this computer so we will see if
the card real culprit or the X79 Chipset has issues with this vid card.

Hello Everyone!

Just wanted to note my experience with my kind of crash and see if anyone can perhaps tell me if there's a workaround or something...or even experience the very same issue.

Before hand here are my rig specs:

ASUS Rampage IV Extreme (LGA2011)
ASUS HD7970-DC2T-3GD5 (with 4 ASUS monitors) - Video Card supports 6 monitors
Intel Core i7-3930K Sandy Bridge-E 3.2GHz (3.8GHz Turbo) LGA 2011 130W Six-Core
Intel 520 Series Cherryville SSDSC2CW180A3K5 2.5" 180GB SATA III MLC Internal SSD (My OS Drive)
WD VelociRaptor WD1000DHTZ 1TB 10000 RPM SATA 6.0Gb/s 3.5"
G.SKILL Ripjaws Z Series 32GB (4 x 8GB) 240-Pin DDR3 SDRAM DDR3 2400 (PC3 19200)
Antec High Current Gamer Series HCG-900 900W ATX12V v2.3 / EPS12V v2.91 SLI Certified CrossFire Certified
WIN 7 OS 64bit

As noted earlier in the thread:

"(it was a 7970 crash e.g. colored screens and hard lock)" by Stich

My crash happens mainly when I open Photoshop, then I get the colored screens and lines and a hard lock that gives my MOBO an error 62 code (PCH Runtime Services), never had a BSOD... been lucky to reset bios some times. It hasn't helped much to have dual BIOS as it happens under any BIOS... I have the latest BIOS firmware on BIOS1 and a lower version on BIOS2. I'm running the latest vid drivers 13.1 catalyst. I've also tried all the old drivers and still get the crash.

It has happened once or twice while playing WoW and watching a movie on another screen. I've played WoW alot with 0 crash. so when i close games and all other stuff and open photoshop both the 32bit adn 64bit I get a random crash of the screens.

I've read that the error 62 I get is due to a faulty or ween Sandy Bridge. I'm no expert though.

Any feedback is appreciated.

I've attached a pic of an example of my screen crash.