cancel
Showing results for 
Search instead for 
Did you mean: 

R9 290 black screens of death

Retired
Not applicable
I originally thought it was caused by some Catalyst bug(s), but after googling it further, I am not so sure anymore.

Symptoms: screen randomly turns black, and within a second the system completely locks up, leaving you with hard reset only. The only interesting thing is it never happens when playing a game (but it happened a moment after closing one down once). It always happened to me when doing random work on the desktop (as in not when idle, which is the other, much more known, black screen problem).

It originally started (or so it seemed) with Catalyst 14.9 and got much worse with the later betas, BUT recently I got a few of these lockups with 14.4, which led me to more googling, and I found posts describing the same problem with even older versions. R9 290 was mentioned in some of them, so I am thinking, could it be a problem related to specific cards?

Has anyone experienced anything like this as well?

My card is R9 290 DC2OC (with the latest BIOS available to date).
26,337 Views
36 REPLIES 36

Mikan02
Level 7
What is GPU voltage at?
Have 4 Matrix-R9290X-P, they are factory clocked to 1050MHz @ 1250mV 😆
> I guess 1000MHz would be around 1220mV.
If on air set an more aggressive fan profile, try match previous temps if possible 🙂
Only times I see blackscreen is when I turn off or on CrossfireX with Asus GPU Tweak on and ULPS off.
I suspect many get this because of slightly too low voltage.

Also have a look at this if you use DisplayPort above 1440p@60Hz.
http://forums.amd.com/game/messageview.cfm?catid=440&threadid=181531

Hope this helps 🙂

Mikan02 wrote:
What is GPU voltage at?
Have 4 Matrix-R9290X-P, they are factory clocked to 1050MHz @ 1250mV 😆
> I guess 1000MHz would be around 1220mV.
If on air set an more aggressive fan profile, try match previous temps if possible 🙂
Only times I see blackscreen is when I turn off or on CrossfireX with Asus GPU Tweak on and ULPS off.
I suspect many get this because of slightly too low voltage.

Also have a look at this if you use DisplayPort above 1440p@60Hz.
http://forums.amd.com/game/messageview.cfm?catid=440&threadid=181531

Hope this helps 🙂


Did you get static flicker and screen locks up with the Matrix?

Retired
Not applicable
Hm, I have mine undervolted a little (-25mV in Afterburner), but I think I was getting the black screen freezes even when I didn't. I'll see what happens when I go back to default. I think it's not related to voltage though, considering I get a lot more freezes with different Catalyst version.

Retired
Not applicable
...nope. Black screen within an hour.

I'm having the same issue, upgrading from a geforce 660TI ...This is pathetic, $400 for a video card that crashes? I'm legit ready to toss this crap in the garbage, screw RMAing it, I have better thing to do anyways..NCIX could have me a brand new 970 weeks before asus gets around to RMAing this junk, I don't want another one if it's going to do this...I've tried everything, nothing works..any ideas?

Done the whole uninstall with DDU and tried different verisons of CCC/Screwed around with different MSI afterburner settings..nothing,

what a Joke, my $180 video card was plug and play, no issues...yet a $400 card wants you to screw with the settings? Please

jab383
Level 13
Catalyst 14.12 lists issues fixed that include sudden black screens. The suggestion: download and try 14.12.

Jeff

Retired
Not applicable
Yup, it seems to be fixed. Finally!

Retired
Not applicable
After several days of premature happiness, I have to say it's not fixed at all 😞 It still happens with the same symptoms.
I also noticed one guy with exactly the same problem who has exactly the same card. I think I saw one more a bit earlier, but can't remember for sure.
Considering how relatively rare this problem is, I think it might be related to the specific card. I don't know, something in the BIOS maybe. I wish Asus could investigate it.

jab383
Level 13
With you on the premature happiness. My card is an ASUS reference R9 290X. It seems to crash when Catalyst is invoked. Catalyst is now removed from the startup programs. It's still in the left-click desktop pop-up, so I can invoke it. That's when I get a black screen, but no others for a few days now.

Jeff