cancel
Showing results for 
Search instead for 
Did you mean: 

Matrix 7970 Platinum - No display!

Lozpetts162
Level 7
Hi guys!
First post here, so I hope it's in the right place.
Fitted my Matrix 7970 Platinum this morning, upgrade from 5770 crossfire, and now starting to run out of ideas!
First the spec of the PC:

Asrock Fata1ty x79 Proffesional
Intel i7 3930k + Corsair H100i
8gb Corsair Vengeance 1600mhz
Antec Earthwatts 650w
Seagate 3tb 7200rpm HDD
WD 2tb Green HDD

The PC starts, everything on the card lights up, the matrix indicator is blue, the PCIe lights are both green, so theres enough power and they are properly seated, and the fans spin.
So far I have tried:
Booting with the card in Safe mode (green flashing matrix indicator),
Updating the Bios on the Motherboard to the latest version,
Reseating the card,
Using a different PCIe slot.

I stick my old 5770 back in and its displays as normal, but I get absolutely no picture from the 7970 at all, not even the post screen. All my USB devices work perfectly.
I've run out of things to try!
34,983 Views
9 REPLIES 9

EllipticDawid25
Level 8
Card is new ?
AMD FX 9370/ CROSSHAIR V FORMULA / MATRIX R9 280X PLATINIUM CROSSFIREx2/ CORSAIR VENGEANCE MEMORY 2133mhz 8GB / ANTEC 1300WATT/ CORSAIR 800D / WATER COOL 360MM RAD PUMP EK 2.2

EllipticDawid25 wrote:
Card is new ?


Yes, brand new!

EllipticDawid25
Level 8
tray psu with more amps i see ur one have 3 lines 22 amps or go to some friend test card when ur gpu have cold solder indicator will be work
AMD FX 9370/ CROSSHAIR V FORMULA / MATRIX R9 280X PLATINIUM CROSSFIREx2/ CORSAIR VENGEANCE MEMORY 2133mhz 8GB / ANTEC 1300WATT/ CORSAIR 800D / WATER COOL 360MM RAD PUMP EK 2.2

EllipticDawid25
Level 8
also u can tray this small swich on card multi screen and single screen might help
AMD FX 9370/ CROSSHAIR V FORMULA / MATRIX R9 280X PLATINIUM CROSSFIREx2/ CORSAIR VENGEANCE MEMORY 2133mhz 8GB / ANTEC 1300WATT/ CORSAIR 800D / WATER COOL 360MM RAD PUMP EK 2.2

EllipticDawid25
Level 8
u can set pcie gen3 in bios this can help 2
AMD FX 9370/ CROSSHAIR V FORMULA / MATRIX R9 280X PLATINIUM CROSSFIREx2/ CORSAIR VENGEANCE MEMORY 2133mhz 8GB / ANTEC 1300WATT/ CORSAIR 800D / WATER COOL 360MM RAD PUMP EK 2.2

EllipticDawid25
Level 8
new card shoudl work with no problem please post back if u check this things
AMD FX 9370/ CROSSHAIR V FORMULA / MATRIX R9 280X PLATINIUM CROSSFIREx2/ CORSAIR VENGEANCE MEMORY 2133mhz 8GB / ANTEC 1300WATT/ CORSAIR 800D / WATER COOL 360MM RAD PUMP EK 2.2

Lozpetts162
Level 7
ITS WORKING! 😄 I flicked the switch and changed the BIOS setting and its working!
There's two versions of my power supply, one has 3 12v rails with 2 pcie's on one, and my version that has 2 larger 12v rails with one pcie on each, so I should be fine.
You are the best! Thankyou so much!

EllipticDawid25
Level 8
im happy i can help u 🙂
AMD FX 9370/ CROSSHAIR V FORMULA / MATRIX R9 280X PLATINIUM CROSSFIREx2/ CORSAIR VENGEANCE MEMORY 2133mhz 8GB / ANTEC 1300WATT/ CORSAIR 800D / WATER COOL 360MM RAD PUMP EK 2.2

EllipticDawid25
Level 8
if u use hdmi display prabobly u set on multi screen use dvi to hdmi adaptor and switch back this make more power on this output for screens with more hz 🙂 and enjoy now 🙂
AMD FX 9370/ CROSSHAIR V FORMULA / MATRIX R9 280X PLATINIUM CROSSFIREx2/ CORSAIR VENGEANCE MEMORY 2133mhz 8GB / ANTEC 1300WATT/ CORSAIR 800D / WATER COOL 360MM RAD PUMP EK 2.2