cancel
Showing results for 
Search instead for 
Did you mean: 

Latest AMD Radeon

ChiefZeke
Level 10
Recently released: amd-catalyst-14.7-rc1-windows-july9 🙂
Lian-Li PC-A77F Full Tower case
PC Power & Cooling Turbo-Cool 1200 ATX12V & EPS12V PSU
ASUS Rampage IV Extreme LGA 2011 X79
Intel Core i7-3960X 3.31 LGA 2011 CPU
Intel RTS2011LC Liquid Cooling Solution
Kingston KHX24C11T3K4/32X (quad 32Gb memory kit) 2 each
ASUS Radeon HD7970 DirectCUII 3Gb GDDR5 PCIe 3.0 x16 Video Card (two in CrossfireX Mode)
Western Digital Cavier Black 2Tb SATA III 6.0GB/S
OCZ Technologies Vertex 4 SATAIII 6Gb/s 512Gb SSD
378 Views
6 REPLIES 6

HiVizMan
Level 40
Thanks for that mate. Downloading now.
To help us help you - please provide as much information about your system and the problem as possible.

I only see a beta for 14.7 - windows 7/8.

http://support.amd.com/en-us/download/desktop?os=Windows+7+-+64#amd-catalyst-packages
Rampage iv Extreme.....3930 i7.....32gb Corsair Vengeance....Thermaltake Water 2.0 Extreme....Matrix HD 7970 x 2 in crossfire....Creative Fatality Champion Soundcard - With front drive bay....Themaltake Toughpower XT Gold 1475 watt power supply.....Samsung SSD 830 512gb...Samsung 1TB HD x 2....Samsung Blu Ray drive....Samsung DVD drive...Windows 7 Ultimate....Thermaltake Overseer RX-1 case

martyn wrote:
I only see a beta for 14.7 - windows 7/8.

http://support.amd.com/en-us/download/desktop?os=Windows+7+-+64#amd-catalyst-packages


http://www.guru3d.com/files/index.html
To help us help you - please provide as much information about your system and the problem as possible.

Thanks for the link H VizMan - and now, for the questions

I have two Matrix HD 7970 Platinum's in crossfire, guessing this driver is ok for them, but, will it bring anything in terms of improvements for me? I had issues with 14.4 turning my lg plasma bg a purple colour instead of black on turning on and reinstalled 13.12

I rolled back to 13.12 (plus hydravision install not inc (is inc in 14.4)).

I found that my LG plasma always had a corrupted screen on switching on, the black rog background became purple, if i took the hdmi lead out and reinserted it was normal colour. also i found if i messed with check on gpu scaling, that would sometimes fix it also.

Click image for larger version

Name: screenct.jpg
Views: 3
Size: 259.7 KB
ID: 38592

above is desktop screen i use - it shows extended displays, my dell u2410 @1920 x 1200 (on left as screen 2 - set main display) my LG 50PZ570T-ZB @ 1920 x 1080 ......... on 13.12 driver

sorry, i forgot to do a capture before removing 14.4

No issues since rollback and nothing else was altered or installed


Above from this thread .. http://rog.asus.com/forum/showthread.php?46450-7970-matrix-black-screen.-RMa-again&p=416774#post4167...
Rampage iv Extreme.....3930 i7.....32gb Corsair Vengeance....Thermaltake Water 2.0 Extreme....Matrix HD 7970 x 2 in crossfire....Creative Fatality Champion Soundcard - With front drive bay....Themaltake Toughpower XT Gold 1475 watt power supply.....Samsung SSD 830 512gb...Samsung 1TB HD x 2....Samsung Blu Ray drive....Samsung DVD drive...Windows 7 Ultimate....Thermaltake Overseer RX-1 case

HiVizMan
Level 40
There is one profile change for dual card but honestly I would not bother. I have gone back to pre 14.4 drivers for performance.
To help us help you - please provide as much information about your system and the problem as possible.

thanks m8
Rampage iv Extreme.....3930 i7.....32gb Corsair Vengeance....Thermaltake Water 2.0 Extreme....Matrix HD 7970 x 2 in crossfire....Creative Fatality Champion Soundcard - With front drive bay....Themaltake Toughpower XT Gold 1475 watt power supply.....Samsung SSD 830 512gb...Samsung 1TB HD x 2....Samsung Blu Ray drive....Samsung DVD drive...Windows 7 Ultimate....Thermaltake Overseer RX-1 case