Showing results for 
Search instead for 
Did you mean: 

Issues with ROG-STRIX-RX570-O4G-GAMING

Level 7
Hi all,

I am in contact with ASUS support, but for the time being, I did not get a helpful answer from them. So maybe someone in the forum can help.

Since the very beginning, I had strange issues with "AC: Odyssey". Just wanted to have a look into the game, as it was shipped for free with the video card. Back then, I was hoping, that a fix for this will be delivered with one of the next driver updates. But till today, nothing happened and I have the exact same behavior as three years ago.

In the last years, more and more games started to show bugs as well. Not as bad as the one from "AC: Odyssey", but also very unnerving. Here a video that shows some of the games: "Fortnite" is now (they apparently changed the game engine to UE5) pretty much the same as "AC: Odyseey" and unplayable.

I have tested various driver versions. No change. Eventually, I have tested my PC setup with an old HD7850 and none of the above happens. Specs of my PC can be found here:

I bought the video card three years ago, so no more guarantee. But maybe someone in the forum has a nice idea for a workaround (besides using the old HD7850 or buying a new video card ;)) or even a solution.


Hi radeon_

Welcome to the ROG forum.

The video with the flashing blocks looks to be a memory issue.

Are you overclocking your ROG Strix RX570?

I do not think so. At least, I never changed any settings.

According to Tweak II, my GPU clock is 1300MHz and voltage 1150mV while memory clock is 7GHz and voltage 900mV.

Thank you,

Try underclocking the memory 100MHz - 200MHz and see if this stops the flashing blocks.

No change. Tried with 6900, 6800 and even 6000. But it does not change at all 😞


Try underclocking the GPU Boost Clock 50MHz - 100MHz and see if this helps.

Be sure to click apply.

No change either. Even if I combine the two underclockings.

Applied it and checked the diagram changed to be sure it got applied. Did not restart the game, but that should not be necessary.

Do you get the flashing blocks while at the desktop with no game running?

Try fortnite again.

With the game running, ALT + TAB out and lower clocks and click apply, ALT + Enter to return to the game and test. You may have to do this a few times.

First of all, thanks a lot for your help!

No, it does not appear on desktop or any program.

Not sure, if you watched the full video. The flashing blocks in AoE4 are, well, ok and one gets used to it. "Fortnite" and "AC: Odyssey" are another level. "Fortnite" here and there even crashed.

GPU clock: 1200MHz
Mem clock: 6700MHz

Started "Fortnite" and it is still a mess. Finally it crashed after half a minute in the first attempt.

I even tried window mode with lowest graphics settings within the game. No luck and a crash.

Other games are good so far, that is why I have not complained after I bought the card. "Dota 2", "AoE2DE", "CSS" are not impacted. Hence I thought of driver issues at the beginning. Only after "Fortnite" changed the game engine last week, it appears also here. Had some issues with a raster of blue dots before if I set shadow details higher than lowest, but I could deal with that.

I have the strong feeling, that this is a hardware issue. But I am curious about what it is. There must be a special part of the GPU that gets triggered by the newer engines or such. No clue. But it is nicely reproducible and very persistent. Best preconditions for bug hunters to isolate the issue 🙂

But even if I know what is wrong, I do not know how to proceed. Asus told me in the meantime, that outside of guarantee, they cannot help:

If the errors persist, we recommend that you have the graphics card checked by a local specialist.
Since we cannot offer you a repair of the card in Asus Service without a guarantee.

You're welcome,

I get the exact same thing in your video if I overclock the Core or memory too far. Since you're not overclocking, it does seem to be an issue with your ROG Strix RX570.

If some games do work ok, this means there could be hope to get fortnite and AC Odyssey running fine too. But, the only thing I know to do is try lowering the clock speeds.

Could try playing with the voltage and decreasing/increasing the power target to see if this might help.

I'm curious what psu you're using.