cancel
Showing results for 
Search instead for 
Did you mean: 

Asus DirectCU II R9 290x - Corrupt bios?

Mattcoker
Level 7
So I tried to update the bios through Asus GPU tweak (when I was in uber mode) but i encountered a hardware lockup (no response on screen, reset button not working), so I powered down as it was the only thing I could do. Now, when I turned it back on it didn't boot. Nothing was showing on the screen, but could see the HDD activity LED on the motherboard showing some sign of life (ASUS Maximus VII Ranger)
After than I switched to the Silent mode on the card and it boots fine, no problem. Tried updating the BIOS through GPU tweak, actually managed to not freeze this time but it failed the flash.
Is there a way round this e.g. flashing the bios on the board?
Any help would be Greatly Appreciated

CPU: Intel Core i5 4690k @ 4.1GHz
GPU: ASUS DirectCU II R9 290x 4G
Motherboard: ASUS ROG Maximus VII Ranger Z97 1150
RAM: Kingston HyperX Savage 2400MHz DDR3 RAM
120GB OCZ Agility 3 SSD
1TB Seagate Barracuda.
Antec Neo Eco 620W PSU
Windows 7 Pro x64
3,271 Views
0 REPLIES 0