cancel
Showing results for 
Search instead for 
Did you mean: 

x670e-plus - last bios build problem 1809

Codeset
Level 8

Hi everyone, here's my problem with this card that's sticking out of my eyes. I've had nothing but problems since I bought it.

I had a first DDR5 16x2 Gskill 6400 kit when it came out that was not recognised and that I had to tweak in terms of timings for it to work at 5800 / 1900.

I changed last month for a dominator platinum RGB 64GB 2x32 6600 kit...

The best I could get out of it and for it to boot and be stable was with the 1616 bios. That is 5800mhz / 2066 with Buildzoid's timings.

Today I tried the latest Agesa 1.0.0.8, i.e. build firmware 1809. Obviously, it's still the same mess, only worse. The PC is even more unstable. The ram can't cope with anything above 5400/1900. Another upgrade for nothing.


EXCEPT... That I tried to downgrade (and by enabling the DOWNGRADE option in the bios). No matter which version I try to flash, I get a corrupted file and can't flash it again. I'm stuck in 1809...


I'm going on 45 and I started with the good old 286... I've seen a lot of ASUS motherboards come and go. If you don't tap into the Crosshair / Formula range any more, you only end up with problems in the mid-range. It's becoming catastrophic. Whether it's AM4/AM5, 1700...

My last purchase was an ASUS. I've never had a problem with MSI, I'm going back to them.

What do we do now Mr ASUS with our bios lock in 1809? We make an RMA on all our cards to have a bios with an older build version ?? Ridiculous.

Got this card with 7xxx gen and now  7950X, i never can exploit them.


639 Views
12 REPLIES 12

Atm the best timings are :

https://www.youtube.com/watch?v=dlYxmRcdLVw

But can't get my 5800/2033 like the 1616 bios version.
New 1809, failed. Downgrade still locked after many tests via USB / local hdd. Most recent build to 1616 binaries.

Norkill
Level 7

I also have the x670e Tuf board, actually created topic here . For me I have GSkill Flare x5 CL36 6000. First two bios versions no problem (maybe with memory context restore and long boot times). Now even after new AGESA (should be better for fast RAM) Im only able to do 5800 with EXPO. My ram even made it at some point to QVL but yeah...

roupa_de_trapo
Level 10