Showing results for 
Search instead for 
Did you mean: 

X670E-PLUS does not post with 128 GB of (supported) RAM

Level 7


I'm running the latest BIOS version (1813) on a TUF GAMING X670E-PLUS WIFI motherboard. When I try to boot with 4x32 GB of RAM (Kingston KF552C40BBK) and DOCP I enabled, system does not POST. After some minutes it runs into some safe POST and I can enter the BIOS setup. If I change the memory configuration to Auto it works but with memory running only at3600 MT/s instead of the base 4800 MT/s or the supported 5200 MT/s via DOCP.

This setup is listed as supported in the QVL list as you can see here:


If I run the system with 2x32 GB, DOCP works as expected. Is this a known issue? Will it be solved in the future? I understand that custom or "weird" setups can fail, but I double check the QVL before buying two additional sticks, so you can understand how disappointing it is to not be able to run them at full speed.


Level 7

I forgot to mention that my CPU (AMD Ryzen 9 7900X3D) supports this setup as well.

Hi @iyanmv 

If you look at the screenshot you’ve provided you can see socket support is only listed as 1,2.

This means ASUS has only validated that the overclocking profile works with two modules. 

This is largely due to a platform limitation. If wanting to utilise all slots and overclock the system you would need to purchase a memory kit validated for 4 DIMMs within the QVL. Alternatively, tune the memory kit manually or run at stock.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090