Showing results for 
Search instead for 
Did you mean: 

[X670e Hero] Error C5. Can't POST at all.

Level 8

The memory kit is Crucial DDR5 Pro (2 x 16GB 5600MT/s 1.1V CL46)

CPU is a Ryzen 9 7950X3D

BIOS version is 1709

I have tried both with only 1 stick in A2 as well as 2 sticks in A2 and B2.


Could you take a picture of the cpu contact side please,  a few angles. The MB pins look fine.

I added a picture of the CPU contacts to the Imgur album just now. It's at the end.

The CPU board pins look fine, the CPU contact plate looks fine as well. 

Just to confirm. You are able to get into BIOS?


I can't even get into BIOS.

Could you please confirm how you know that your bios is version 1709? Did you use the flashback feature?

Yes, I used the flashback feature. Judging by the flashing blue light it completed successfully. Currently, there's no way to confirm it, though.

Ok, so let's assume the bios did update successfully.

Did you update the bios because of the c5 code? Or you just did it because you wanted the latest version before you started using the pc?

I updated it because I wanted the latest version before installing any of the components. Since, the newer versions of BIOS cap the voltage on vSOC, I also wanted it so that my new processor wouldn't die.

Makes total sense especially with those 3D versions of the CPU.

After you got the C5 error, did you try to reset the CMOS? Could be done via the jumper or via the battery. After bios update this is usually not required but maybe...just maybe.

I have removed power completely from the system and held down the clear CMOS button at the back for 10 seconds and am still having the issue. I even tried to remove the battery as well.