Showing results for 
Search instead for 
Did you mean: 

x670E-F Gaming Wifi -> Bios Update going really bad and help for Flashback

Level 7

Hello there,

The story : i've bought a ROG x670E-F Gaming Wifi and a Ryzen 9 7900xd3 for a new rig.
Everything went fine for the initial mount, and then i've seen that the bios was 5 versions away... so EZ Flash

First pass went good and then rebooted (EZ Flash)... second one went good and then rebooted (EZ flash) -> Message "successufly updated) and after the 3rd reboot : a last message, not in EZ Flash (just the CLI) saying update is finishing, keep it steady, and then shutdown and... death

No lights on the motherboard : it's powered up as i see a PCI Network card alive on it. But the MB itself it silent and in the dark. The Aorus leds next to the CPU are dead.

I've requested support on the ROG website, but in the meantime i wanted to try flashback, and here i need a bit of help

I've currently created a FAT32 USB Key, with MBR and only the flash file i need, but i never get Flashback to work : i simply have no led either on the USB Key or the Flashback led.
I've looked at some videos and i see that the motherboard should also show led activity when alive (the AORUS logo)

So my questions : Can Flashback also be bricked or that's impossible ? Or i'm missing something ? I've saw people saying that the CPU has to be removed, some saying the CPU power has to be removed, some about having only one RAM populated, etc....

Currently : I've got the motherboard fully naked (no CPU, RAM, etc...) just main power and CPU power connected. And still no lights anywhere.



Level 7

I can't see that you did a CMOS reset (button or jumper) My mobo wouldn't do anything when pressing the power switch - CMOS reset thankfully worked.


I've tried, multiple times, but without luck. 

I don't have the MOBO anymore : ROG support requested me to send it back directly to where i've bought it. It's currently being "investigated"

Mare !!  Good Luck.