Showing results for 
Search instead for 
Did you mean: 

X670E-E Bios 1004 Released

Level 8

I just upgraded to 1004 Bios,a couple of minutes ago, and graphics card issue appears to be solved. Beginning other testings...


Level 8

I'm going to stick with this Bios for now.

Some Testing Results Bios Update 1004

- Firts Boot from Bios Flashed or Resetted: 1 minute and 30 seconds
- Unrecognizable GPU problem: Solved
  GPU MSI 3080Ti
  Never failed to boot Windows 11 Pro
- Can't enter Bios booting PC: Not Solved.
  The only way to enter Bios is Clearing CMOS
  Same bahavior, no time to press F2 o Del keys. Tested Restarting and Shutting Down.
  Every test with black screen all the way through Windows 11 first screen displayed
- Sometimes white light on motherboard, randomly
  I think this could be a normal behavior or something between PCI-E GPU and Integrated GPU.
- RAM 6000MHz Overclocked Expo I, II or Tweaked: Not Solved
  Every other BIOS option is Default
  Always white light on motherboard
  d6 Q-Code
  Turning on time: (maybe normal behavior, improved timing compared to old BIOSes)
  1 minute and 20-30 seconds (first time)
  1 minute and 0-5 seconds (second time, restarting)
  Overclocked Succeeded
  System passes Cinebench test without issues
- RAM Default and PBO Advanced with -20 All cores CO
  Randomly white light on motherboard
  System boot
  1 minute (immediately after saving BIOS settings, splash screen displayed, plenty of time to press F2 or Del)
  36-38 seconds from second attempt onwards
  Randomly, white light on motherboard, ROG splash screen present, no time to press F2 or Del

I have an X670E-A in a new PC that I just built back in mid-Feb.

Last night I reset the BIOS to defaults and then flashed from 0922 to 1004.

  • Upon first boot, motherboard stuck on white LED. Subsequents boots after that were fine.
  • On previous BIOS, time from pressing power button to Windows 11 desktop = 52 seconds. Now = same.
  • RAM set to "EXPO II" has never been problematic for me. What is the issue you are having? I have this: G.Skill Trident Z5 NEO RGB Series (AMD Expo) 32GB (2 x 16GB) 288-Pin SDRAM DDR5 6000 CL30-38-38-96 1.35V Dual Channel Desktop Memory F5-6000J3038F16GX2-TZ5NR (Matte Black)
  • I can always enter BIOS by rapidly pressing F2 during POST. I noticed that 1004 now has an option to select how many seconds to display the "Press F2 or DEL to enter BIOS" message with the default set to 3 seconds. See if that option helps for you.
  • I have PBO enabled and curve optimizer set to -15 on all cores. So far, so good*.
  • I also have the following set for my Ryzen 7 7700X CPU: PPT Limit: 100,000; TDC Limit: 75,000; EDC Limit: 150,000.
  • Everything else in my BIOS is stock/default.

*Known issues: about 10% of the time, launching Doom Eternal gets stuck at "TELEPORTING", and the main game menu, or while playing. All other games run fine. Still testing everything though. So many moving parts!


Tigerdave, thanks for asking.

My only problem, at the moment, is memory overclocking. I can apply any of the three options and my PC seems to work fine with any of them. But, as soon as I apply one of them, my PC goes from 34 seconds to boot up to about 1 minute, and I always get this white LED light on the motherboard and Q-Code d6 while the computer boots up. Finally, I can see an increase in idle temperatures from around 46°C to around 52. Also, I can't see much benefit running DDR5 4800 vs. 5600, 5800 or 6000.

We are in the same boat. I too do not notice a difference with enabling "EXPO II" or any profile for that matter -- other than longer boot time. I may end up disabling it going forward. Right now I'm still trying to dial in the optimal PBO Curve Optimization. If I set ALL CORES to -15, everything seems stable, but I'm still trying to fine tune it and go even lower using PER CORE.

So I started tinkering with AMD Ryzen Master again yesterday, and whenever I do, my PC hangs on reboot and I have to CLEAR CMOS. I ran PER CORE optimization with it yesterday running a 1-minute test on each, and it ended up setting each core to -30 which is way too low. Because when I ran OCCT to test, it threw a bunch of errors for a few seconds and then Windows self-rebooted into a blue screen. Too low.

More testing to come.

Good to know I'm not alone with this issue. I'm running PBO All Cores -25. I've got my best numbers with this configuration.