cancel
Showing results for 
Search instead for 
Did you mean: 

X670E Crosshair Hero - Bricked 2 boards in 2 days

wyliec2
Level 7

Incredibly frustrating experience...new X670E Crosshair Hero with 7950X CPU.

First board - used Flashback to update BIOS to 2007 before installing CPU.

Installed CPU and system posted - began installing Windows but wired network wasn't working.

Switched to wireless and that worked. Installed Windows 11 Pro.

Installed driver updates from the included ASUS USB presuming it would fix the ethernet issue. On the next restart, the system went through a variety of qled codes before stalling on d6 with VGA (white) and BOOT (Green) lights lit.

After many iterations of CMOS reset, trying different BIOS versions (flashback works without issue) contacted ASUS support who suggested RMA or return to retailer.

I'd just bought this board two days earlier from Microcenter, so I returned the board and got a replacement.

This time I left BIOS alone (shipped with 1709) and mounted CPU, etc. Started it up and wired ethernet was working fine. Updated the Chipset drivers from the ASUS USB and restarted - worked fine.

I thought I'd try incrementally updating BIOS and drivers and restarting after each step.

I installed BIOS 1905 via flashback and BOOM - back to d6 with white and green lights lit. Thought reverting to 1709 would resolve it....but no, now this board is bricked...

Ultimately, I plan to upgrade CPU when next gen comes out, so seeing BIOS 2007 accommodates next gen prompted me to go ahead with the 7950X build. I'd had good results with the 570 Crosshair VIII starting with a 3950X and later upgrading to 5950X. I've done several high performance builds with ASUS boards but I think I'm done with that now....Incredibly frustrating experience. A dozen or so builds with many updates and I've never had a bricked board and now I've got 2 in two days....  😞

408 Views
4 REPLIES 4

Braegnok
Level 14

If your running Ryzen 7000 series CPU on X670E, I would advise to stay on BIOS 1904, or 1905. And if running Ryzen 8000 Series use current beta 2101, or 2007. I tested both 2007, 2101 with X670E, 7950X and had issues after a few days running high frequency memory profiles. Personally I will not update BIOS till I have Ryzen 9000 CPU in hand, the newer AGESA versions adding support for upcoming CPUs work very well in default settings, no issues on my system. 

 

 

Bensirpent07
Level 8

I'm guessing you ended up finding no fix for this? I just upgraded my MB and CPU to X670E Hero and a 7800X3D. First boot resulted in going straight to the d6 error. That was without doing any flashing. I tried a couple different BIOS versions but ultimately never got it past the d6 with white and green LEDs.

Fanaticism
Level 8

Ok so what power supply do you guys have? Also, a known fix for this problem, is too shut down, turn psu off, press power button to denergize the capacitors, unplug the gpu, plug the connected back in and make sure it’s firmly pushed in. Then turn your system on, if you still get d6 error unplug and plug in the DP cable if the monitor won’t turn on. This worked for my crosshair board. 

Every recovery effort possible had been tried and the boards would not recover. The steps were confirmed with ASUS support. Since I was using the IGPU, my monitor connection was HDMI (only display connector on the motherboard). I did try a GPU instead of the IGPU but the error remained.

Interestingly, I had an MSI board do the exact same thing - again using the IGPU on the 7950X CPU. At this point I'd swapped everything except the CPU itself.

I returned the 7950X and picked up a 7900X and a new MSI MEG X670E Ace motherboard from local Microcenter. This time I went straight to using external GPU (3080 Ti) and avoided the IGPU.

I was able to complete the build successfully and everything is now working. The 7900X results were disappointing compared to the 5950X build I'd been using. I wound up returning the CPU to Microcenter and got another 7950X from another source (Microcenter doesn't have the 7950X).

All is working well now and I'm getting a nice performance improvement over the previous platform.

7 builds in 5 years and never had an issue anything like this...just glad it's resolved now!!!