cancel
Showing results for 
Search instead for 
Did you mean: 

X670e Asus TUF + 7600X - Wild instability. Benchmarks crashing. BSODs.

NBlast
Level 8
I'm posting this issue in several places, to try to find some hints what wrong is happening here. I will describe the whole tour I made with my new PC. I hope it is a good way of giving some ideas what is happening. I currently suspect the motherboard for this issue, but CPU or RAM isn't out of the question yet. I hope you might have some ideas...

My specs:

GPU: NVIDIA GeForce RTX 4070 Ti (AD104-400) [ASUS]
CPU: AMD Ryzen 5 7600X
Motherboard: ASUS TUF GAMING X670E-PLUS WIFI
BIOS Version: Previously 0807, Currently 0821
RAM: 2x16GB G.Skill Trident Z5 6000MHZ CL36 (F5-6000J3636F16G)
PSU: beQuiet! Pure Power 12 M
Case: Fractal Pop Air
Operating System & Version: WINDOWS 10
GPU Drivers: GEFORCE GAME READY DRIVER - WHQL Driver Version: 528.49
Chipset Drivers: 4.1.02.829

What is happening:

System degrades it's stability depending on the current max clock setting in PBO options in Motherboard's BIOS. Ranging from outright Windows Bluescreens on "default" clock boost values (5.450GHZ - yes, it's weird, I will explain), to crashes in Time Spy at -100MHz, to crashes on 4K display in Forza Horizon 5 benchmark at -150MHz, to seemingly normal operation at -200MHz.

Troubleshooting:


  • The best way to explain the situation would be to describe every single action I took so far.
  • PC was build in a electronic store. Due to shortages of parts, store provided everything except PSU, SSD, Cooler and Case. Those elements were purchased separately
  • Store build the PC, turned on XMP profiles, installed Win10 and tested the system on some unspecified benchmark.
  • Brought PC to home. Started testing. System worked well.
  • Started testing on Time Spy and FH5. Had crashes: 3DMark aborted tests and FH5 crashed to desktop
  • Investigated. Disabled XMP profiles in BIOS first. Frequency of crashes lowered, but didn't dissapear.
  • Updated MoBO's BIOS from 0807 to 0821. No dice
  • Found this thread: https://community.amd.com/t5/processors/amd-7600x-am5-7000-platform-instability/td-p/567604 with similar symptoms. Per information there, I turned that option, not exactly knowing what it does. Max CPU Boost Clock Override (-) = 150. I'm not that knowledgeable in overclocking. I was thinking that my MoBo was configured so no additional OC was set up.
  • Question 1: Why does exactly this ASUS motherboard allows up to 5450MHz Boost clock?! I thought that 5.3GHz is allowed max without OCing.
  • Question 2: What does AUTO option in PBO settings exactly entails? So far I had it to auto. I have no idea if that makes PBO turned on or off by default.
  • Testing at -150. Enabled XMP again. Every benchmark passed with flying colors!
  • Next day: Hooked up 4K TV. FH5 benchmarks started failing again.
  • Went to BIOS. Set up -200 for a limit
  • Tests returned to normal. No crashes in FH5 or in HL: Alyx for that matter.
  • Next day: Decided to do more investigations. Wanted to try a MemTEST86
  • Went to BIOS. Wanted to go for the default settings so I reset it to "Optimized Defaults" per Asus BIOS
  • Windows went haywire. Bluescreens everywhere. Different reasons. I cannot stay in system for more than 30 seconds. Using WhoCrashed app to highlight issues, those are several of errors I have got: SYSTEM_SERVICE_EXCEPTION, ATTEMPTED_WRITE_TO_READONLY_MEMORY, SYSTEM_THREAD_EXCEPTION_NOT_HANDLED_M
  • Enabling/Disabling seems to have no effect.
  • Reducing clock speeds by -150 seemed to make Bluescreens go away.
  • Making PBO: DISABLED in BIOS, triggered Bluescreens again.
  • Tried MemTEST86. When CPU clock speed was limited by -200, both on/off XML profiles passed test with no issue.
  • MemTEST when CPU clock was not limited (Auto). I don't remember exactly, but it seemed that non-XMP test passed, but having Auto PBO settings and XMP made either immidiate test errors or I couldn't enter MemTEST at all (stuck on Calculating Memory/CPU speeds)



I hope for some explanations what the hell is going on here. I would much appreciate any clearing on this issue
2,645 Views
5 REPLIES 5

nestar91
Level 8
Hi,
also Team "AM5 Instability" here lol.
My bluescreens are gone now since Updating BIOS on my B650E-I to Version 1222 and resetting CMOS. Also Update Chipset drivers to Version 5.xxx
But games still crash after a few rounds of playing.
My Post here, hoping for some answers.
https://rog.asus.com/forum/showthread.php?132441-New-AM5-Build-unstable-Game-crashes&p=885801#post88...
I now will try to test another 7600X, maybe the cpu is faulty. or its just the whole system, with new AM5 Board, BIOS still faulty.
If i am not able to play games in the next 2 weeks, i think i will switch to Intel.

Yeah. Your problem seems to be very similar to mine! Please, if you manage to get that another 7600X to test, share your findings. Good luck!

I had awful problems with the 528.49 Geforce driver, similar to the problems you describe.

Upgrade to 531.18 and that might solve your issues.

NBlast
Level 8

That PC was sent to a store for investigation. I had no information about what the hell happened there, but I've got a new CPU and updated Bios to 1222. System is stable-r, with better luck in keeping stability on that weird stock 5.45GHz overclock, but requiring toning down in PBO setting to -150GHz to keep stable in Forza.

It's okay, but I have other problem described in the other thread. Thanks for hints so far.

Atricus
Level 7

I have a probleme with my tuf x670e plus wifi + ryzen 7700x

Post very slow

When i enable

Memory context restor as i found on forums that speed up boot time post

Post time is shorter than before

But when in win sometimes got to black screen or restarr or when boot to win i have error with blue screen

Stop code:IRQL_NOT_LESS_OR_EQUAL

What code : ntoskrnl.exe