Showing results for 
Search instead for 
Did you mean: 

X670 resource


ill use this thread to collect some new test bioses for the boards, maybe also to explain some less understood options

to disable cores ccd go here and choose ccd xx bit map down core.
each ones stand for an enabled core
best to disable from the back, ie:
instead of 0011000
after selection press downcore apply changes or discard if made mistake


7950x not boosting pass 5.5G -> check that CStates is not disabled
Detailed Explanation on CState Boot Limiter

Test BIOSes:

X3D OC Preset for those MB with asynch BCLK Support: (for simple slight perf boost for X3D)

DOCP/EXPO Tweaked: (for simple timings tightening)

strixe-e 1515 

strixe-f 1515 

strix e a 1515 

crosshair hero 1515 

crosshair gene 1515 

crosshair extreme 1515 

creator 670 1515

creator b650 1515

strix 650E I

strix 670 itx



for crosshair and strix e-e:

explanation of segment2 Loadline:


customize a heterogenous loadline for a dual segment workload range.

example above shows loadline=L6 when current is in range of 0~40A, and Level4 when current is above 40A.




Adds for x3d

dynamic ccd priority switch with core flex, os / driver agnostic so win10 win11 ok



Algo as follows:
If condition reached and ccd0 specified, then check current mem/cache activity > threshold and hysteresis reached, if fulfilled then switch
If condition reached and ccd1 specified, then check current mem/cache activity <=threshold and hysteresis reached,, if fulfilled then switch
Default hysteresis =4

Can combine multiple algos for ccd priority so combinations are wide

works on non x3d too but of course senseless on it. detailed explanation here.

2,386 REPLIES 2,386

Level 10

Had to go back to 1004. I was getting too many hard lock ups (black screen, fans ramp to 100, and can't reset unless I turn off the PSU) with the 1101 bios. Also, under 1101 I was getting more frequent USB, NIC, and Audio dropouts and straight up disappearances. At least with the 1004 I can turn off the Thunderbolt/USB4 and cut down on those dropouts. They don't go away but they become MUCH less frequent. With 1101 turning on or turning off Thunderbolt/USB4 seemed to make no difference. I just dropped out a LOT more. 

Level 10

18:40 mark. 


"My biggest fear, actually, is the Asus motherboard. There have been SOOOO many reports of Crosshair Hero and Crosshair Extreme motherboards just failing. Bad motherboard traces. Apparently bad memory traces have been discovered. Which is kinda, I think, on the Extreme specifically. Which I think is exactly what happened to my Asus Hero. Ummm. Its been frustrating. And considering the fact that the problems didn't show themselves until a week later has me very scared for. Am I gonna last a month? Two months? Six months? If it starts to become problematic then what I'll more than likely do is keep the 7950x3d and switch to another brand."



Level 7

Still having USB PCIe expansion card initialization issues. Coin flip if it's going to show up in Windows when I get logged in. Manually setting PCIe generation per slot doesn't help. 

Level 10

do the core flex algos have any impact on chips w a single CCX? (7700,78000x3D,etc)?

Intel 3770K 4.4ghz, 1.24v. . . . . . . . . . . . . .Intel 4930k 4.7ghz 1.37v........AMD 7800x3D async 104
32 gGSkill DR3Trident 2400mhz 1.65v. . . .32 g 1866 Vengeance Pro.......64 g Hynix 6200
ASUS M5G. Noctua D14. . . . . . . . . . . . . . . H110. Noctua A14x4.............Arctic 420
prime95 stable 78degrees. . . . . . . . . . . . . IBT 75 degrees
OCZ V4 OS. . . . . . . . . . . . . . . . . . . . . . . . . EVO 1TB...............................WDSN850x 2TB
Seasonic 700w. . . . . . . . . . . . . . . . . . . . . .1200AX.................................HX1200i
All tucked into Lian Li A05. . . . . . . . . . . . . .Fractal Midiv2......................BeQuiet802

Level 8

Maybe @Shamino could share if all these stability problems come from AGESA or just ASUS BIOS? It's unaceptable that these problems are still not resolved after all these months since release. I do get that ASUS BIOS dev team might be understaffed or some other corporate bs, not blaming the devs, but this is beyond ridiculous.

Level 10

i had to go back to 0805. 1101 had better boottimes with MCR / PDE on enabled. but this setting causes errors on Karhu with Cache enabled bettween 400 and 1000% ( i canceld after 1000%).  QVL Ram G.SKill 6000C36 on D.O.C.P II

Same settings with 0805 - no errors.  I have Cosshair Extreme. This BIOS thing is unbelievable - i built a PC for X-Thousand of Euros and i have to deal with Bluescreens, Errors, Bootloops, E00, and so on

Level 10

1101 also bootet often my 4090 to PCIE-SPeed 3.0 or it got no sensor Data so the PCIE-ran on 16x1.1 ......... with 0805 no problems. 

Do we know when new Agesa 1.0.07 will come? 

That is not a bug, it is a feature, NVIDIA runs at PCE4 1.1 on IDLE but as soon as you kick some GPU workload will revert back to PCI full 4.0, check below GPUZ on my 4090 IDLE vs GPU worload (game in the back running)




SOMETIMES IDLE with a bit of browser is even switched to PCIE 4 2.0 



Justo to conserve power i guess makes sense.



Screenshot 2023-04-10 125254.pngi


i know about the "?" and that pcie goes to 1.1 in idle and 4.0 under load. 

My prob looks like this (picture) and when i do a TimeSpy i have like 5fps because the PCIE Speed stays at 16x1.1

Ok trying to help , since you are aware and already excluded this scenario, just a few questions to try and maybe find the root cause:

1 - Did you update the chipset drivers with latest?

2 - Are GPU drivers well installed (maybe uninstall , full reboot, then reinstall, full reboot again before any test)

3- Did you tried to actually kick in other software , games etc, to check is the same scenario?

4- If using windows 11 did you set "Hardware-accelerated GPU scheduling" On? should be!

5 - In Bios is REBAR on? should be!

6 - If nothing of this works (or already tried all) - suggest boot to bios , load all defaults, set just your EXPO profile , set CPU VSOC to 1.25v nothing more! and check again!

7 - All failing either revert to previous BIOS working or reflash BIOS with full reset settings!

Hope it helps! If not well ... tried--- 

Clarification, i am running bios 1004, not latest 1101 or whatever is the latest now , because i also had a lot of issues lately with BIOS updates , se my posts before!

AMD/ASUS X670 boards have been a hit and miss lately full of issues , don't know who is in fault here and don't care ASUS is the vendor needs to step up and solve all this! Otherwise my only final advice is just keep you most stable BIOS until good news starts to happen!