Showing results for 
Search instead for 
Did you mean: 

X670 resource


ill use this thread to collect some new test bioses for the boards, maybe also to explain some less understood options

to disable cores ccd go here and choose ccd xx bit map down core.
each ones stand for an enabled core
best to disable from the back, ie:
instead of 0011000
after selection press downcore apply changes or discard if made mistake


7950x not boosting pass 5.5G -> check that CStates is not disabled
Detailed Explanation on CState Boot Limiter

Test BIOSes:

X3D OC Preset for those MB with asynch BCLK Support: (for simple slight perf boost for X3D)

DOCP/EXPO Tweaked: (for simple timings tightening)

strixe-e 1515 

strixe-f 1515 

strix e a 1515 

crosshair hero 1515 

crosshair gene 1515 

crosshair extreme 1515 

creator 670 1515

creator b650 1515

strix 650E I

strix 670 itx



for crosshair and strix e-e:

explanation of segment2 Loadline:


customize a heterogenous loadline for a dual segment workload range.

example above shows loadline=L6 when current is in range of 0~40A, and Level4 when current is above 40A.




Adds for x3d

dynamic ccd priority switch with core flex, os / driver agnostic so win10 win11 ok



Algo as follows:
If condition reached and ccd0 specified, then check current mem/cache activity > threshold and hysteresis reached, if fulfilled then switch
If condition reached and ccd1 specified, then check current mem/cache activity <=threshold and hysteresis reached,, if fulfilled then switch
Default hysteresis =4

Can combine multiple algos for ccd priority so combinations are wide

works on non x3d too but of course senseless on it. detailed explanation here.

2,456 REPLIES 2,456

Can't comment on the J3040, but my J3038 run fine with EXPO I.

Would love to know as well, normally ASUS are the ones to get new AGESAs out the door first 🙂

Got the same memory. runs fine on Expo tweaked for almost a year now across various bios versions on X670E Extreme

Level 9

I have the same issue. PCIE Gen drops randomly to 3.0 x 16 / 1.1 x 16 (heavy stuttering). Setting the PCIE Gen in the BIOS gets ignored when the bug occurs. Even setting the alteration mode switch to Gen 4.0 is overwritten.

7800X3D, X670E Gene, 4090

I can't enable RTX Super Resolution or often when my PC boots, Windows will be slow and laggy and after a short while my PC reboots. Sometimes rebooting my PC before it randomly reboots fixes it, but now I just leave super resolution disabled. 😞

It happens on my RTX 4090 AND my 3060.

I don't use RTX Super Resolution.

I tried a lot of things and maybe I recently got rid of this exact same bug, or I was just really lucky for the last few weeks and it just hasn't reappeared. The PCIe stuck at 16x v1.1 problem was happening with my old 6800XT as well as with my 4080 Super, so I know it is not a GPU problem. 

Anyway, first try setting Post Report to at least 6s or more in boot settings. Sometimes there can be problems with initialization. Secondly, too high SOC voltage can also be a problem. I settled on 1.21V (instead of 1.25V that my 7800X3D defaults at with EXPO ON). But again, maybe I am just very lucky. Previously this bug would happen often, mostly on restarts, but on cold boot as well. It doesn't hurt to try!

Thanks for the input. I've tried a lower SOC voltage / POST delay 10 sec and it still randomly initializes PCI gen 3.0 / 1.1

Interesting. I've been bothering with this problem for months and after I changed those two things the problem went away. Maybe I was just lucky? Or the problem will randomly reappear, I really don't know. Oh, and try disabling fast startup as well, or however that is called. Also, make sure that you aren't overdoing your curve optimizer settings.

Level 9

Hello, on my 670E-E with the latest BIOS and 7950x (MLB ON), I'm using negative CO.


Unfortunately, I can only reach -5 on the best core, and everything seems to be working fine, under load, gaming, CB23, AIDA etc..

However, when the system is cold (fresh start), typically during writing an email in a browser, the system restarts, but it happens very rarely.


Is there a way to determine which core the error occurred on? Is there any log where I could find this information?

My SP info if its help:

I cant belive that -5 CO on best core is still a high.

Setup: 7950X, Strix X670E-E, 32GB 6000 C36, RX 7900 XTX 24GB GDDR6, WD BLACK SN850X NVMe 2TB, Asus ROG STRIX SCOPE RX, ASUS ROG Gladius III Wireless

Level 9

Don't worry, my 7950x3D can also only go down to -7 CO. (don't know SP value now, but I guess pretty terrible ^^)