cancel
Showing results for 
Search instead for 
Did you mean: 

X670 resource

Shamino
Moderator

ill use this thread to collect some new test bioses for the boards, maybe also to explain some less understood options

to disable cores ccd go here and choose ccd xx bit map down core.
each ones stand for an enabled core
best to disable from the back, ie:
110000
instead of 0011000
after selection press downcore apply changes or discard if made mistake

ocpak/octools

FAQ:
7950x not boosting pass 5.5G -> check that CStates is not disabled
Detailed Explanation on CState Boot Limiter


Test BIOSes:

new:
X3D OC Preset for those MB with asynch BCLK Support: (for simple slight perf boost for X3D)
97792

DOCP/EXPO Tweaked: (for simple timings tightening)
97793

strixe-e 1515 

strixe-f 1515 

strix e a 1515 

crosshair hero 1515 

crosshair gene 1515 

crosshair extreme 1515 

creator 670 1515

creator b650 1515

strix 650E I

strix 670 itx

 

 

for crosshair and strix e-e:

explanation of segment2 Loadline:

dualseg.jpg

customize a heterogenous loadline for a dual segment workload range.

example above shows loadline=L6 when current is in range of 0~40A, and Level4 when current is above 40A.

 

 

 


Adds for x3d

dynamic ccd priority switch with core flex, os / driver agnostic so win10 win11 ok

97403

97404

Algo as follows:
If condition reached and ccd0 specified, then check current mem/cache activity > threshold and hysteresis reached, if fulfilled then switch
If condition reached and ccd1 specified, then check current mem/cache activity <=threshold and hysteresis reached,, if fulfilled then switch
Default hysteresis =4

Can combine multiple algos for ccd priority so combinations are wide

works on non x3d too but of course senseless on it. detailed explanation here.

434,632 Views
2,054 REPLIES 2,054

RobrPatty wrote:
If you flash with there posted bios you get....ComboAM5PI_1005c_RC3 is the AGESA version. Not the ComboAM5PI 1.0.0.5 patch C


If you see my post above , you will se that i tested the 0922 BIOS and reverted after somehow the 0922 BIOS on high CPU usage is making some short circuit to the board or CPU and bringing my house power down! I did not tried to find the root cause because i am not their BETA tester, and i am sure the culprit is that f$%%up bios that should not even be online to download, because i reverted back to 0805 and system got back to stable and normal!

The point i am trying to make is no matter if AGESA is BETA or not AMD / ASUS are launching crap software/bios without proper testing , and subjecting us cause serious harm on high end hardware, and i suspect just to speed up and launch X3D CPUS , ignoring support for the "older" already launched!

I am waiting on ASUS to comment back all this bad experiences in 0922 BIOS most are having!

Soupladel
Level 10
It’s funny that it’s been a couple days now and a few people have commented that 0922 is causing problems on otherwise stable systems and ASUS have gone radio silent on the matter.

I have always bought ASUS kit where possible but I am really disappointed in how AM5 has gone so far, initially I was willing to give the benefit of doubt given it was a new platform but we are past that and I am not sure we should be still be having these kinds of issues.

Despite what has been said about the c-state limiter, I am still not convinced it is working as intended on my board because I never see anything abov 5.5Ghz even on single core workloads

Soupladel wrote:
It’s funny that it’s been a couple days now and a few people have commented that 0922 is causing problems on otherwise stable systems and ASUS have gone radio silent on the matter.

I have always bought ASUS kit where possible but I am really disappointed in how AM5 has gone so far, initially I was willing to give the benefit of doubt given it was a new platform but we are past that and I am not sure we should be still be having these kinds of issues.

Despite what has been said about the c-state limiter, I am still not convinced it is working as intended on my board because I never see anything abov 5.5Ghz even on single core workloads


I think they not work in weekends....

dordoka
Level 7
I've had 2 random reboots and 1 random shutdown in 24h. ROG Strix x670e-e gaming BIOS 0922. No error on event manager. No custom PBO curve applied, just PBO enabled. Tried to disable C-States but no luck.

dordoka wrote:
I've had 2 random reboots and 1 random shutdown in 24h. ROG Strix x670e-e gaming BIOS 0922. No error on event manager. No custom PBO curve applied, just PBO enabled. Tried to disable C-States but no luck.


I had random reboots with no blue screen or event logs other than the unexpected shutdown message. For me it was either too low of an offset in curve optimizer or too high IF clock. I am still trying to figure out which it was.

Tyberious wrote:
I had random reboots with no blue screen or event logs other than the unexpected shutdown message. For me it was either too low of an offset in curve optimizer or too high IF clock. I am still trying to figure out which it was.


Thanks for your reply. I didn't have any curve set up. Downed IF speed a bit and disabled Medium Load Boostit.

I just want a stable system FFS. DDR5 is a major PITA, at least on AM5. I miss the times where i could just set up an XMP/DOCP profile and everything worked.

I've been sitting back and waiting for more info to come out about 0922 and I guess I'll try it this evening after work.
So far, 0805 has been stable but I like to tinker...

Running X670E Hero and 7950X with GSkill 32gb DDR5 kit F5-6000J3038F16GX2-TZ5NR.

Will report back either way once I get time to mess with it.

dvcspl wrote:
I've been sitting back and waiting for more info to come out about 0922 and I guess I'll try it this evening after work.
So far, 0805 has been stable but I like to tinker...

Running X670E Hero and 7950X with GSkill 32gb DDR5 kit F5-6000J3038F16GX2-TZ5NR.

Will report back either way once I get time to mess with it.



Updated to 0922 with zero issues. EXPO I enabled and UCLK=MEMCLK set to 1. No cold boot issues, no BSOD yet. Benchmarked a few times. All seems well so far. Will update as it goes.

dvcspl wrote:
Updated to 0922 with zero issues. EXPO I enabled and UCLK=MEMCLK set to 1. No cold boot issues, no BSOD yet. Benchmarked a few times. All seems well so far. Will update as it goes.


I wish I could figure out the reason why mine was so unstable at cold boot. I didn't set UCLK=MEMCLK to 1 though. Maybe that was it?

ekarren wrote:
I wish I could figure out the reason why mine was so unstable at cold boot. I didn't set UCLK=MEMCLK to 1 though. Maybe that was it?


I kept having random hard crashes in Pro Tools when using more than 16 plug ins. I found this post (https://rog.asus.com/forum/showthread.php?130981-New-build-freezes-or-BSODs/page2#post876364) where he explained setting the UCLK=MEMCLK and it fixed everything. Now everything runs suuuper smooth. Boot time is about 40 seconds to Windows 11, previously it was over a minute. Used to get a bunch of hardware failures in the reliability checker and now it's been a nice little uphill climb to stability.

FWIW, I did update to the new AMD Chipset driver that was available via the ASUS website - it's still not available on the AMD website..
I saw someone mention above they were having USB and network dropouts - I have yet to experience this. I'm also using the onboard NIC at 2.5G with no issues.
Wonder if the USB issues are related to overtightening the CPU cooler? That's been proven to happen in the past; too much force on LGA can shift/distort pin placement.

Full Specs with 0922 bios:
Crosshair X670E Hero
7950X
EK 360 Elite AIO
EVGA 3090Ti FTW3
GSkill F5-6000J3038F16GX2-TZ5NR
Boot drive: Sabrent Rocket 4.0
Storage drives: WD Blue NVME, Samsung SSD, WD SSD, Sabrent external 16TB USB
USB devices: GoXLR, RME ADI2-PRO, Glorious GMMK, Glorious Model D Wireless, Elgato Stream Deck, Oculus Rift, Razer Kiyo Pro Webcam, LianLi Connect 3 Hub.