Showing results for 
Search instead for 
Did you mean: 

X670 resource


ill use this thread to collect some new test bioses for the boards, maybe also to explain some less understood options

to disable cores ccd go here and choose ccd xx bit map down core.
each ones stand for an enabled core
best to disable from the back, ie:
instead of 0011000
after selection press downcore apply changes or discard if made mistake


7950x not boosting pass 5.5G -> check that CStates is not disabled
Detailed Explanation on CState Boot Limiter

Test BIOSes:

X3D OC Preset for those MB with asynch BCLK Support: (for simple slight perf boost for X3D)

DOCP/EXPO Tweaked: (for simple timings tightening)

strixe-e 1515 

strixe-f 1515 

strix e a 1515 

crosshair hero 1515 

crosshair gene 1515 

crosshair extreme 1515 

creator 670 1515

creator b650 1515

strix 650E I

strix 670 itx



for crosshair and strix e-e:

explanation of segment2 Loadline:


customize a heterogenous loadline for a dual segment workload range.

example above shows loadline=L6 when current is in range of 0~40A, and Level4 when current is above 40A.




Adds for x3d

dynamic ccd priority switch with core flex, os / driver agnostic so win10 win11 ok



Algo as follows:
If condition reached and ccd0 specified, then check current mem/cache activity > threshold and hysteresis reached, if fulfilled then switch
If condition reached and ccd1 specified, then check current mem/cache activity <=threshold and hysteresis reached,, if fulfilled then switch
Default hysteresis =4

Can combine multiple algos for ccd priority so combinations are wide

works on non x3d too but of course senseless on it. detailed explanation here.

2,257 REPLIES 2,257

Level 9

I swapped my Radeon 6800XT for a MSI 4080S Gaming X Trio and I have the same problem - sometimes the GPU will be stuck in PCIe 16x 1.1 mode, especially when not cold booting (restart or wake from sleep). This must be a problem related to AMD CPU/Chipset on my B650E-E.

Does it affect your frame rate, or could it just be a reporting issue?

Level 9

With my 6800XT it killed my framerate. I also tried 3DMark PCI bandwidth test and it showed numbers consistent with PCIe 16x v1.1.

On my new 4080 Super, it also makes the desktop laggy, in addition to killing performance.

There are clear signs that it is apparently very difficult to get PCIe to work properly with AM5 boards. The ProArt X670E I have had problems with the link width (never one link's bandwidth/PCIe version), especially with UEFI version 1807, much less so with the prior ones. Now with versions 1904/5 the PCIe connection seems to work properly again (that is PCIe 4.0 x16 with a Radeon Pro VII card). M.2 PCIe works currently also well (PCIe 5.0 x4 & PCIe 4.0 x4).

Others like you report link speed/PCIe type problems, not link width, with earlier and the more recent firmwares... what on earth could cause this kind of inconsistent behavior between GFX cards, mainboard's hardware and firmware versions, and even some kind of randomness when booting?

Level 9

I found some people with the exact same problem over on MSI forums, so PCIe running at 16x v1.1. Very annoying. But when it runs at 16x v4.0, there are zero issues no matter what tests I run. 

Level 9

Strange, maybe it's somehow an AGESA bug in the never version that support Phoenix if even MSI boards are affected.
I am still on 1809 on my X670E TUF, zero issues with link speed and disappearing nvme drives.

Every time I've checked in GPU-Z on cold boot, reboot, been x16 4.0.

BIOS 1905.

Level 9

Looks like I diagnosed the problem with PCIe link randomly being permanently stuck at 16x v1.1.

Beta version of Win11 and a complete fresh install (of non-beta W11) didn't fix the issue. Then I noticed on one of the forums that AMD pulled the chipset driver (V5.11.02.217) from their website shortly after releasing it for unspecified bugs, yet that is the official chipset driver on the Asus support website for my B650E-E. Uninstalling the driver and installing a new one from AMD website (v6.01.25.342) didn't solve the problem, but another fresh W11 install with only v6.01.25.342 did.

Level 9

Nevermind, turns out that I was just lucky and the problem didn't reappear until today. The annoying thing with the new GPU (4080 Super) is that now even the desktop lags when I'm stuck in PCIe 16x v1.1. mode, so I need to restart the PC until it is no longer stuck in v1.1. mode.

******, that it is really annoying 😕
I hope this gets fixed soon - very frustrating that the changelog are so super vague all the time, so we actually don't know what has been fixed/changeld or not.

@SAFEDISK any chance you can share detailed changelog when new BIOS releases, at least here in this forum when you post new BIOS?