Showing results for 
Search instead for 
Did you mean: 

X670 resource


ill use this thread to collect some new test bioses for the boards, maybe also to explain some less understood options

to disable cores ccd go here and choose ccd xx bit map down core.
each ones stand for an enabled core
best to disable from the back, ie:
instead of 0011000
after selection press downcore apply changes or discard if made mistake


7950x not boosting pass 5.5G -> check that CStates is not disabled
Detailed Explanation on CState Boot Limiter

Test BIOSes:

X3D OC Preset for those MB with asynch BCLK Support: (for simple slight perf boost for X3D)

DOCP/EXPO Tweaked: (for simple timings tightening)

strixe-e 1515 

strixe-f 1515 

strix e a 1515 

crosshair hero 1515 

crosshair gene 1515 

crosshair extreme 1515 

creator 670 1515

creator b650 1515

strix 650E I

strix 670 itx



for crosshair and strix e-e:

explanation of segment2 Loadline:


customize a heterogenous loadline for a dual segment workload range.

example above shows loadline=L6 when current is in range of 0~40A, and Level4 when current is above 40A.




Adds for x3d

dynamic ccd priority switch with core flex, os / driver agnostic so win10 win11 ok



Algo as follows:
If condition reached and ccd0 specified, then check current mem/cache activity > threshold and hysteresis reached, if fulfilled then switch
If condition reached and ccd1 specified, then check current mem/cache activity <=threshold and hysteresis reached,, if fulfilled then switch
Default hysteresis =4

Can combine multiple algos for ccd priority so combinations are wide

works on non x3d too but of course senseless on it. detailed explanation here.

2,371 REPLIES 2,371

Level 10

I have 0 USB issues since it got solved in 1802. however i still have one sandisk usb stick that refuses to work.

Works fine though if i plug it in and boot the pc. so could be software but idc much anymore about that stick. dont want a reinstall

I have had issues with my external USB HDD (although I've only tried them in the front ports) with Linux with my Crosshair x670 Extreme. I have never tried tried using such a drive in Windows.

I have had a lot of trouble with my drive... What happens is that I'm unable to mount the drive at all right after boot, or I'm able to mount, but I soon start having issues. I can resolve these by restarting the system. When the drive works... It usually works for a long time... but eventually stops.

I'm doing monthly backups. Once the backup is done (in usually less than an hour), I perform a full filesystem scrub which takes ~9 hours. On a "good" boot, this will go well for hours and it will usually start to have issues more than half way through. Either, performance will be severely graded or IO errors will prevent the scrub from finishing. Either way, I have to reboot and resume the scrub.

I completed a backup and filesystem scrub yesterday with 1904, and had to resume the scrub after around 6 hours or so.
I also will have issues POST'ing if I tried to start the machine with the drive plugged in. Sometimes my system boots up fine. Other times, it's very slow or never boots at all.

Level 8

Asus boards are just crap, I have x670e hero and x670e gigabyte with totally the same configuration and settings and ram timings with sub timings. Gigabyte works perfectly, and Hero reboots or does not turn on at all.

Level 8

Had to downgrade from 1904 to 1807 on the x670e Hero. I had an issue for the longest time where my 4090 wouldn't be detected after reboot (would have to power down and do a cold boot), an issue that 1807 fixed. Looks like 1904 brought the issue right back... Sigh 😕 I am getting so tired of this issue where my dGPU isn't detected and instead, boots in the background to the iGPU and hangs at the BitLocker screen (which I can see after changing inputs) before shutting down due to it timing out. When I enter my key and boot into windows in that state, my 4090 does not even show in task manager. I have bought the Hero x470, x570, and now x670e. If they can't get this squared away, I'll be skipping them on my next build as this has been by far the worst experience I have had with any Hero board until now. Also still irked they took away the bios speaker output so I know what it is doing during bootup based on the sounds it would make.


I have made new tests this early morning with some of my seagate HDDs external 2,5" I have here (different size).

(Test is a simple test if work fine on a rear USB 3.0 and one on only one USB 3.0 port).

- Seagate Backup plus 1To: NTFS - Nearly empty, just few big data backup.

Work fine on rear USB 3.0 (just test one rear port) and the front USB 3.0 port.

- Seagate expansion plus 2To: NTFS - Half empty with mainly mp3 files. 

Work fine on rear USB 3.0 (just test one rear port) and the front USB 3.0 port.

- Seagate expansion plus 4To: NTFS - 3,5To with movies files.

Work fine on rear USB 3.0 (just test one rear port) BUT DON'T WORK AT ALL on the front USB 3.0 port.

(nothing on the explorer program, impossible to eject, buzy mouse pointer but switch off computer work this time).

The same problem with another 4.TO HHD seagate with movies files (this one nearly full) I have tested yesterday (first post here).


Problem with big HDD (4to) with lots of files on it. (Don't have empty HDD 4To for testing).

Level 9

I have issues transferring files (writing) to a thumb drive or a external drive from the very begining. No Bios have solve it till now. This is my second motherboard (the last one with build date end of September 2023, and the first one one year earlier, in sept 2022), so it should not be a early product issue.

The rare thing is nobody is speaking loud about it. For me is a deal breaker as I usually work with external drives (working with  video editors and files) , but no solution is found. Disabling "disable device to save energy" nor disabling PCI express link energy savings solve the issue.

The way I workarround this is using the front USB-C connector, even this has it's own drops for data transfer is already working (tilll now). In my case Front or rear connectors does not change anything.

But actually my guess is that is more a windows 11 issue than a MB issue. The reason I think this is because if I start windows 11 in "Secure Mode", I have no issue with the USB's. 

Next image is a transfer of a video file. This dips in speed are gone in "secure mode". Also in my old trusty intel i9700k on ASUS Maximus XI Hero Wifi all transfers are perfect, stable and without error.

Something is wrong either with drivers or SO, but strange enough nobody speak loud about is even for me is "Basic" functionality.



10Go copy on front USB 3.0 with SAMSUNG BAR 256Go : around 100 mo/s (model 2023). Follow specs

10Go copy on front USB 3.2 with Samsung (MUF-256DA/APC), 256 Go : around 100 Mo/s (model 2023). Follow specs.

10Go copy on front USB 3.0 with  USB 3.0 JumpDrive 128GB : around 10-20 mo/s (model 2016).

10Go copy on front USB 3.0 with P20 128Go USB 3.0 JumpDrive : around 250mo/s (model 2016). follow specs.

10Go copy on front USB 3.0 with Black 16GB 3.0 Flash Drive USB : Same like you - 60 first to 10 mo/s (model 2020).

I don't have your problem with recent or known manufacturer.

I have slow copy speed with manufacturer like my lexar or my Sandisk cheap model.

The problem of my is with HDDs 4To with front USB 3.0 port and I hope someone else will confirm.

USB key is like electrical cars about range, mostly are liars.

Level 7

The LED firmware is faulty in BIOS 1904 of the ASUS ROG Strix X670E-E. Aura mainboard can be controlled and Aura Addressable 1 to 3 can no longer be controlled. It stays on “Rainbow”. My previous bios was 1807.

Check you're on AC  and AuraSync 3.07.33. There's a new build due in the coming days, though.


13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

now it's working.