Showing results for 
Search instead for 
Did you mean: 

X670 resource


ill use this thread to collect some new test bioses for the boards, maybe also to explain some less understood options

to disable cores ccd go here and choose ccd xx bit map down core.
each ones stand for an enabled core
best to disable from the back, ie:
instead of 0011000
after selection press downcore apply changes or discard if made mistake


7950x not boosting pass 5.5G -> check that CStates is not disabled
Detailed Explanation on CState Boot Limiter

Test BIOSes:

X3D OC Preset for those MB with asynch BCLK Support: (for simple slight perf boost for X3D)

DOCP/EXPO Tweaked: (for simple timings tightening)

strixe-e 1515 

strixe-f 1515 

strix e a 1515 

crosshair hero 1515 

crosshair gene 1515 

crosshair extreme 1515 

creator 670 1515

creator b650 1515

strix 650E I

strix 670 itx



for crosshair and strix e-e:

explanation of segment2 Loadline:


customize a heterogenous loadline for a dual segment workload range.

example above shows loadline=L6 when current is in range of 0~40A, and Level4 when current is above 40A.




Adds for x3d

dynamic ccd priority switch with core flex, os / driver agnostic so win10 win11 ok



Algo as follows:
If condition reached and ccd0 specified, then check current mem/cache activity > threshold and hysteresis reached, if fulfilled then switch
If condition reached and ccd1 specified, then check current mem/cache activity <=threshold and hysteresis reached,, if fulfilled then switch
Default hysteresis =4

Can combine multiple algos for ccd priority so combinations are wide

works on non x3d too but of course senseless on it. detailed explanation here.

2,386 REPLIES 2,386

You’re not the only one. For me it started with 17xx bios’s. My bus powered USB disks fail to copy files screaming that resource is no longer available. And indeed no issue when connected to rear ports. 

Level 9

But I have the same issues on the rear ports. I tested with 3 of them, not all of them, but the issue is still the same. So issue is, in my case, with all USB ports. And on the other hand,  I have issues from the beginning (I think first bios version was 14.01).

What's more, is that I got my Motherboard replaced (original was November 2022) with a new one from October 2023. So either all the motherboards have the issue or the issue could be AMD/SW related (yes I install from scratch, formating disk again).

One important point to support what I said is starting in Safe Mode, I have no issues copying files to the USB. Speed is maintained without issue and goes to the end without errors (tested several times).


Then it could be a conflicting driver. 

Level 9

I continue with my reported issue testing and I will be adding a little more light to the issue: If I fomat the external card to NTFS ¡¡there are no errors!!. So the culprit is located to exFAT  driver (exfat.sys. that I checked and it is Microsoft Genuine) and AMD (because it does not happens on my old Intel computer) . So probably drivers. 

Screen capture with NTFS formated Card. Already copyed 140GB without error (I did the test 3 times, this is the 4th time)



The problem for  me is that the external memory card, fomated as exFAT, is used within the GOPRO so I can not leave it as NTFS. So.... no I see no solution as of now, but at least it is clear is not a HW issue.

My HW is:

  • Asus Crosshair x670E Hero
  • 7950x3D CPU
  • 64 GB Kingston memory (VQL)
  • No overclock
  • Windows 11: 23H2, installed from scratch.

Please, if someone can do the test to copy a very large file (more than 100GB) to an external sd card , fomatted as exFAT,  through USB 3.0/3.1/3.2 adapter or card reader to confirm the same issue will be great. 


Level 9

Thanks Olav, but I think, well actually sure that is not the root cause for the issue:

  1. from USB-C or USB2 headers the issue is not reproducible.
  2. Formatting from GOPRO have the same issue (I detected it first time this way).

So the issue is located at driver level (It seems or some other weird app interfering). I reported the issue to Microsoft, but I doubt they do something about it. It is a very excepcional (I think) use case .

Level 7

Dear Readers,

I'm trying to run 4 DIMM's of Corsair 32GB (CMK64GX5M2B6200C32), on a ROG Extreme x670e, with DCOP at 6200MHz, but for some reason the system won't POST, and returns to safe boot. When i only run with 2 DIMM's this run's fine with, DCOP I, II and Tweaked. but 4 won't work. Also tried various other RAM configurations, but anything other than the stock, won't POST.

Are there any hints to solve this?

Thanks Olaf

No way you will be able to run 4 dimms of 32GB each AND at 6200MT/s. Those are double sided so no, lol.
The only supported 4x32GB kits are from Kingston, according to X670E-E QVL. And that's at 5600MT/s at most.


You will need manual timings and A LOT of voltage to even have a chance on running your kit full speed while also being stable.


AMD Ryzen 9 7950X3D | ROG Crosshair X670E Extreme [1905] | Sapphire Nitro+ Radeon RX 7900 XTX Vapor-X | G.Skill F5-6000J3040G32GX2-TZ5NR | 2TB Samsung 990 PRO | 2TB Samsung 980 PRO | 2TB Samsung 970 EVO Plus | Samsung Odyssey Neo G9 | ROG RYUJIN III 360 ARGB | ROG Thor 1200P | ROG Chakram X | ROG Strix Flare II | ROG Theta 7.1 | ROG Cetra True Wireless | ROG Balteus Qi | ROG Eye S | ROG Aura Terminal | ROG Throne | ROG Spotlight | ROG Strix Arion | Windows 11 Pro

Level 8

I have an ASUS ROG B650E-F GAMING WIFI motherboard and I upgraded to beta version 2204 with AGESA and I noticed that Epic Games Launcher crashes when playing Fortnite. Checking the reliability history of Windows 11, the problem started for the first time right after installing this firmware version, I already reinstalled Epic Launcher and even Windows 11 23h2 and nothing solved.

The second problem is the change of the PCI-E 4.0 x16 version to 3.0 or 2.0 under load. I plan to go back to firmware version 1807 to see if I reverse these problems.

AMD 7800X3D
Crucial 2TB T500 NVME NVME PCIE 4.0
DeepCool PX850G 850W
2x16GB DDR5 6400 XPG LANCER RGB (EXPO Tweaked)

Level 9

@666CZR I found myself in a similar situation. I used 2 Kits from TeamGroup, each of which was 16Gb x 2 and had an XMP profile at 7200 (T-Force Delta RGB). Clearly, such a setup would never work at such a frequency - but I didn't need it to. I purchased this memory because they were the world's first memory sticks on Hynix A-die. All that was needed from them was to work at the 6000 frequency with the lowest possible timings. And they were working at 28-36-36 timings (on BIOS 0902), but with each subsequent update, things got worse and worse. With the 1807 update, they even refused to pass POST at a 6000 frequency even with 50-50-50 timings. Raising or lowering the voltage did not affect this at all. I was desperate and eventually just bought ADATA XPG Lancer AX5U6400C3232G-DCLABK - a kit of 2 sticks of 32Gb, with an EXPO profile at 6400Mhz, and 32-39-39 timings. They are also based on Hynix A-die. This particular part number is not in the QVL, but there is another one with RGB lighting and white color from the same product line. Replaced RAM and now everything works beautifully - EXPO I, EXPO 2, and Tweaked.