Showing results for 
Search instead for 
Did you mean: 

X670 resource


ill use this thread to collect some new test bioses for the boards, maybe also to explain some less understood options

to disable cores ccd go here and choose ccd xx bit map down core.
each ones stand for an enabled core
best to disable from the back, ie:
instead of 0011000
after selection press downcore apply changes or discard if made mistake


7950x not boosting pass 5.5G -> check that CStates is not disabled
Detailed Explanation on CState Boot Limiter

Test BIOSes:

X3D OC Preset for those MB with asynch BCLK Support: (for simple slight perf boost for X3D)

DOCP/EXPO Tweaked: (for simple timings tightening)

strixe-e 1515 

strixe-f 1515 

strix e a 1515 

crosshair hero 1515 

crosshair gene 1515 

crosshair extreme 1515 

creator 670 1515

creator b650 1515

strix 650E I

strix 670 itx



for crosshair and strix e-e:

explanation of segment2 Loadline:


customize a heterogenous loadline for a dual segment workload range.

example above shows loadline=L6 when current is in range of 0~40A, and Level4 when current is above 40A.




Adds for x3d

dynamic ccd priority switch with core flex, os / driver agnostic so win10 win11 ok



Algo as follows:
If condition reached and ccd0 specified, then check current mem/cache activity > threshold and hysteresis reached, if fulfilled then switch
If condition reached and ccd1 specified, then check current mem/cache activity <=threshold and hysteresis reached,, if fulfilled then switch
Default hysteresis =4

Can combine multiple algos for ccd priority so combinations are wide

works on non x3d too but of course senseless on it. detailed explanation here.

1,741 REPLIES 1,741

I ran Cinebench immediately following an upgrade to 1602 on Strix e-e yesterday. I always set defaults/reboot, upgrade the Bios then enable Expo II, enhancement 70c and MCR/PDM. The score was about 1,000 points lower than 1516. Shutdown overnight. Without any changes, ran Cinebench again today and the score was back to where 1516 was. Not sure if there is something funny about that first boot or if I just had some concealed background process that interfered.

Level 10

Is there any difference between the 1602 posted here and the one on the official website?

Also I don't think anything has changed in this BIOS that would hinder the performance. I've done a ton of tests and the performance is basically the same as in 1516

Level 8

Tried 1602, System became unstable again, constant crashes.  Aida64 stability test saying system hardware failure.  Expo again needed to be disabled to stabilise and even then benchmarking was approx. 10% slower.  Reverted to 1516 and everything working again, 1516 is the first firmware for the x670e-hero that I dont have problems with.  Dont know whats changed between that one and this, but for me, it's not a change for the better.  Happy to try out any suggestions.

Same here the 1602 is total unstable and the system freeze without BSOD.

Level 7

I run extreme with corsair 196GB kit, never was able to go over 3600 default speed; any other settings would not pass memory test. with 1602 it picked it up at 5200 and running like a champ. 

On my hero on bios 1516 and 1602, now four modules are not loaded even at 4800, the C5 code stupidly shows as soon as I change the frequency from 3600 to 4800. The further - the worse the support for 4x32 GB modules .... Although still on the BIOS 1415 - worked for 4800

Level 10

Another day of testing and still worst performance ever on this bios on my strix 670e-e with 7950x3d.

Here are my manual settings I always set in every new bios:

1- Expo tweaked
2- Medium load boostit - enabled
3- PBO enhancement 80*C
4- CPU VDDIO/MC Voltage from 1,4V to 1,35V
5- Audio, wifi, bluetooth - disabled
6- integrated GPU - disabled
7- powerd down enabled - enabled
8- memory context restore - enabled

Any advices ? Maybe something in this bios is disabled or was enebled and it is on auto now ?

Level 10

Try a full Bios reset.

Pc off and 1x press of the CMOS clear button and again 1x press BUT for 2 seconds the CMOS clear button

This really deletes all settings in the bios and after starting the PC all settings are set to standard.


Maybe there is another setting in the bios that wasn't deleted properly. Actually, the setting is reset after every bios update, but I've already read in some other forums that this probably doesn't happen properly and some settings remain set and cause errors.

AMD Ryzen 9 7950X3D | ROG CROSSHAIR X670E EXTREME | ASUS TUF Gaming GeForce RTX 4090 OC | G.Skill F5-6000J3040G32GX2-TZ5N | WD Black SN850X | PHANTEKS Glacier One 360 T30 Gen2 | LG OLED42C27LA | Phanteks NV7 | Seasonic PRIME-TX-1300

Level 9

1602 takes around 10 minutes to post when restarting system everything is at default only docp 2 enabled on ram.

Enable Memory Context Restore to retain the last successful training.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090