cancel
Showing results for 
Search instead for 
Did you mean: 

X670-P BIOS ans ARGB

GreeBeeKoo
Level 7

Hey,

i just recently bought the X670P and am having some trouble updating the bios. I got the most recent non-beta-version and put in on 2 USB-Sticks on FAT32, renamed the bios and went to EZ flash. With both drives the new firmware showed up and started updating - for 1-2 Seconds. After that the PC rebooted with no display out and remained like that for 15-20 Mins, then i forcefully shut it down. A reboot later it boots normally but with the old bios. I tried agein with a different Drive, same story.

How csan i update the bios? Is it a version problem?

(Specs: X670-P, 7700X, 32GB 6000/CL36 RAM, 1TB NVME PCIE4/Slot2)

Also ARGB isn't working. I tried all headers, armory crate doesnt recognize devices, Signal RGB doesn't, only my unifans (but on the hub) are working correctly.

Connected to the ARGB headers are EK-Nucleus AIO CR360 D-RGB, an ARGB Lightstrip and the Lightstrip of the case. It seems like only one LED on each one is light (green)

Thanks for the help in advance,

Ben

225 Views
6 REPLIES 6

Nate152
Moderator

Hello GreeBeeKoo

After you download the bios to your pc, you should see the bios file and bios renamer.

Extract the files to your usb flash drive by clicking bios renamer. (Don't copy the bios file and rename it.)

How does it go using this method?

 

GreeBeeKoo
Level 7

Hey Nate, thanks for the Fast answer. Sadly it's just the same, progressbar starting, immediate reboot....

Nate152
Moderator

You're welcome and strange it still won't update.

Try deleting the bios file off your flash drive and redownloading it.

I recorded a video just to make sure you're doing it right. I'm using the ROG Strix Z690-F Gaming Wifi motherboard but the download and update should be similar. I used the 1410 beta bios as an example for the video.

 

GreeBeeKoo
Level 7

Did it exactly like that, but there is a difference. The extraction takes some time in your video. In my case it takes only several seconds. Assuming my CPU isn't 10times faster than yours this seems strange.#

Btw. I reformatted and redownloaded BIOS every time again for a new try, also tried with the beta one,still the same.

 

Nate152
Moderator

If the extraction is going super fast, it sounds like it's not putting everything on the usb flash drive.

Double click on bios renamer, click extract all, select your usb flash drive as the destination folder.

Any difference?

GreeBeeKoo
Level 7

Extraction still went super fast, got 32MB uncompressed, was even starting to write how it's not worth even trying, but still did. It finally worked! Honestly don't know what made the difference, but still. Thanks for your help!