cancel
Showing results for 
Search instead for 
Did you mean: 

USB Issues on X670E Bios

GhostOfficer
Level 8

Turnin "USB power delivery in Soft Off state (S5)" off from bios results in some usb ports not working in Windows 11. There is an error "The USB hub failed to reset"

ROG CROSSHAIR X670E HERO BIOS 1602 & 1516

 

9,284 Views
48 REPLIES 48

GhostOfficer
Level 8

Thread title changed since it is not only Crosshair X670E Hero that has USB issues with bios (1602 & 1516). 

vanerik23
Level 7

I'm on a X670E TUF Gaming Plus WiFi Board and I have never had this issue before. I tried updating to the latest BIOS (1654) 2 days ago and I've been having the same USB issues. I can't login to windows to check if there are any other USB devices that aren't working so I can't really tell if it's only specific ports or if it's all of them. Rolled back to previous BIOS (1636) and the issues are gone. I've been having very minor motherboard issues ever since I bought this board but it does not affect any functionality or performance so I tried updating the BIOS to see if that fixes anything. Just adding to this thread so I can follow-up later if there has been any fixes.

Silent_Scone
Super Moderator

Hi guys,

This issue has been flagged and requires an AGESA patch. Keep an eye out for future firmware updates 👍

 

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

dennydeutscher
Level 7

Hello, 

I’m still forced to boot my pc twice every morning to get USB working properly. Are there any news about the firmware... 
It's annoying!

LumKitty
Level 9

Well the new BIOS is out for my TUF X670E, with an AGESA update.
Still got the exact same issue 😞

Also on a TUF X670E. What version did you update from? and what version did you use before having the issue?
I was on 1636 and the issues started in 1654. I rolled back and the USB function properly for now.

1654. 1636 probably would sort it, but 1654 contains unspecified "performance improvements" and I'm not sure what they are. Plus in these days of CPU and chipset level security updates, I'm always worried about running a much older BIOS.

Silent_Scone
Super Moderator

 

The issue was discovered on PI 1090 but AMD has decided to wait for PI 1100 before rolling out a fix. Currently not able to provide a timeline, I would just keep those patches in mind 👍

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

frenzyff
Level 10

intresting, trying to fix this issue for many months now. but never a decent answer. following thread.
At first suspected Rog Throne....

Using 670E-E

Babartheme
Level 8

Right, I thought I was going mad it was just me as googling for weeks didn't turn up anything but I found this thread.

I am experiencing the same issue on my X670E ASUS ROG CROSSHAIR GENE, on cold boot I get error 43 on 2 USB controllers in device manager, irrespective if I am overclocked or not.  I do use USB S5 power state off, because my ROG STRIX AIO CPU cooler will sit there glowing colorfully if I don't, and I don't want to kill the mains all the time for that.  Also full ROG Gear, including the azoth keyboard.  

I need to power on, then reboot once, and my USB devices work fine after that. 

On one hand though I am really pleased to find this thread because I thought I was going to need to RMA my board (and god help us, ASUS support took 3 days to come back to me on my ticket, imagine what a repair would be like.)