Showing results for 
Search instead for 
Did you mean: 

Two Asus Rog Crosshair x670e Extreme's stuck on memory test

Level 7
Had a system happily humming along for twoish months with the following specs:
Motherboard: Asus Rog Crosshair x670e Extreme
CPU: AMD Ryzen 7950x
RAM: 2x32GB G.Skill Trident DDR5 6000
GPU: RTX 3090 FE

I installed a PCIe SSD that I've used in other systems and the box wouldn't boot. It was stuck at "memory test" with a motherboard code of 00. I removed the PCIe card, same error. Went through all the standard items of removing components, moving ram, clearing CMOS, etc etc. Same issue. Contacted Asus tech support, they issued me an RMA with a 7+ day turnaround time.

I need my system for work so I drove two hours and picked up the exact same motherboard. Came home, swapped everything and... Same issue. Replaced GPU, same issue. Found a post mentioning Asus' compatibility page which I gleefully ignored at build time and realized that my RAM was not on the list. Ok, headed to Best buy. Picked up 2x16GB Corsair Vengeance 5600MHz DDR5 C36 DIMMs. Installed it and - yup, same issue.

I saw a post on here saying to leave the box up and running for a while so the system could "learn" the memory. So I've left it running - I'm at 48 minutes and still at the memory test. What now? Could my CPU be fried?

Level 9
You have the ram in the correct slots, right? Reset cmos and if you can get into the bios try running memory at default speed not EXPO.

Yes, I followed what was in the manual and then tried using just one DIMM, alternating slots. I've never changed RAM timing.

I've already cleared the CMOS and can't get into the BIOS to change any settings.

Level 10
I can tell you that you are not the only one. In various forums there have been the same reports for weeks.

Here is an answer from the German ASUS Service Support in a German forum from last week:

The Ram problems are reportet.
We ask you to stay with the old Bios Version for the time being and wait for a New Bios that will be released soon. Unfortunately, the New Year celebrations in China/Taiwan mean that the offices are not occupied, which leads to some delays.
AMD Ryzen 9 7950X3D | ROG CROSSHAIR X670E EXTREME | ASUS TUF Gaming GeForce RTX 4090 OC | G.Skill F5-6000J3040G32GX2-TZ5N | WD Black SN850X | PHANTEKS Glacier One 360 T30 Gen2 | LG OLED42C27LA | Phanteks NV7 | Seasonic PRIME-TX-1300

You have shown it is not the MB or memory and likely not any other component since you tested without most. Did you leave out GPU and boot on iGPU? I also assume the second MB had a older BIOS so that is not it either. Sounds like CPU to me; maybe something shorted when you opened it up to add the SSD.

Level 7

Had same issue. Got a new MB. 

Level 7

Hi, I had this very issue, but thanks to some help from the retailer who built the system; solved it. The BIOS version this worked on was 1303 which was the latest version as of 2023/04/27 - WARNING - It takes a lot longer than usual to update with this version than is normal.

Test Memory looping on C5, chances are that your BOIS Update has not completed. The latest BIOS Update as mentioned above takes a whole lot longer than usual. Even when your board states that the BIOS update has been successful it isn't finished. It has only been written to the BIOS, but still has to update further, which will require 4 or more resets and information as to the status will be shown on screen. Be patient.

BUT, if you have accidently interrupted it thinking it was finished, then you are likely to loop forever on C5 and if you are looping regardless, then keep reading:

The fix is easy, but it does require the loan of a different RAM. The fix is to 'TEMPORARILY' swap out your original ram. The BIOS Update will then automatically complete and then you can swap back your original ram. And everything should now work. BUT remember this is not a quick BIOS Update, so give it time. The ram that I'm using is Corsair Vengeance DDR5 2x32GB:

CMK64GX5M2B 5600 Z40
40-40-40-77 1.25v version 4.43.02

MB: ROG Crosshair x670E Extreme
CHIP: AMD 9 7950x

I hope this helps at least some of you.

Level 14

Hello jerkychew,

Perhaps you have too much pressure on your CPU cooler.

Shut-down PC, loosen all four corners of CPU cooler, pull both memory modules, and firmly reset one module in DIMM Slot A2, confirming tab is locked, module is fully seated.

Re-start PC,.. see if PC boots.

If yes, then shut down and install second module in DIMM Slot B2,.. same as above firmly seating, confirming tab is locked, module is fully seated. 

Screenshot 2023-04-28 152018.jpg

Intel 14900KF ~ Asus MZ790A ~ 48GB DDR5 ~ RTX 3090 Ti ~ Crucial T700 SSD ~ SeaSonic TX-1600 ~ Praxis WetBench ~ Full Custom Water.

Level 9


Hi, I've been tinkering a lot with the new platform too and managed to get it sorted out.

Try setting it up in the bios
In boot menu - fast boot > disable
In AI overclock set EXPO profile
In the memory timing settings set: Power Down Enable > disable
And last, probably the most important point, set CPU core voltage manually to 1.2v at best, 1.25v at worst.

It should work then

ROG Strix X670E-E, Ryzen 7900, 2x16 Gb Dominator Platinum 6000Mhz

The issue for most is getting into the BIOS in the first place. If your stuck on Memory Lock then you cannot get into the BIOS to change anything.

Additional Information: 2023/05/31

I was finally able to fix the issue by removing all my RAM and temporarily replacing it with a different ram. This forced the Bios to read the memory again and finish the Bios update. I then was able to reinstall my original ram.

The real issue was that the bios update hadn't finished. It was a major update which took extremely long and I think that is what caught many out. But in doing this I was able to gewt into the Bios and complete the update. The system has been fine ever since. I hope this is of help to someone.