Showing results for 
Search instead for 
Did you mean: 

TUF X670e WiFi. Green Q-LED, stuck on boot occasionally. Looking for help

Level 8

Hello again. I'm still fighting with issues on my new PC, since I got it. I posted a thread before about this particular one, but I noticed it lacked all the needed information, and I couldn't edit it. I also got few discoveries along the way, so I want to start from square one.

My PC specs:

ASUS TUF GAMING X670E-PLUS WIFI  | AMD Ryzen 5 7600X |NVIDIA GeForce RTX 4070 Ti [ASUS] | 2x16GB G.Skill Trident Z5 6000MHZ CL36 | beQuiet! Pure Power 12 M 1000W | PNY CS3040 NVMe x4 2TB
BIOS Version: 1222 | Chipset drivers:


SOMETIMES. After a boot I am greeted with UEFI - Enter BIOS screen without way to enter it. Q-LED is sticking to the green color. Previously I thought this mean that everything was okay, but later I read the manual, that it might be a problem of not finding the boot device. Usually a one restart by power button brings the computer back to Windows. Frequency varies from 2-10 boots between the issue.

Before noticing the Q-Led, what I tried:

  • Reinstalling Windows and formating the main boot drive
  • Disconnecting the secondary SATA SSD
  • Disabling fast boot in Windows
  • Clearing CMOS

After I noticed the Q-Led, I opened my PC and tried to re-seat my main PNY SSD. It didn't look like it was connected incorrectly. Unfortunately, this didn't help and I still get this issue.

Any further ideas what do to? Should I try to put this SSD to the other M.2 slot? If so, which one would be okay? Should I wait for the release of BIOS 1410 to try it? Is there anything more I can do?



Hello NBlast,

Do you have your ssd in the M.2_1 slot? If yes, then all good.

In the bios, have you set your gpu and M.2 ssd to Gen 4?

I have an Intel motherboard but it should be similar, this is found under the pci express settings.




Thank you for the response!

Yes, my SSD is currently in the M2.1 slot. If I'm assuming correctly, that one is the "fastest" with PCIe x5 speeds and closest to CPU, right?

As for the putting on Gen4 settings for GPU and SSD in BIOS:  I will definitely try it out! However, I do have a question about it. I think that this option limits the PCIe speeds for GPU and SSD from x5 to x4, right? This won't affect current and future performance? For SSD I think this shouldn't be a problem, since I have PCie Gen 4 part anyway.... But, I'm not exactly sure when it comes to the GPU.


You got it right, the M.2_1 slot is where you want your ssd.

PCI-e 5.0 somewhat future proofs you as you can use pcie 5.0 gpu's when they're released. 

Both your gpu and ssd are PCI-e 4.0, Gen 4 is the setting you want for both of them.

Level 8

Options set. Thank you again! Will report that if this issue gets reproduced again. This can take some time.

Level 8

Problem happened again. This time it took longer, but it's still happening. I plan to update BIOS right now, but I will wait until a new version won't be a BETA one.

Any other ideas how to tackle this issue? If BIOS doesn't help I'm going to swap places of SSD to another spot on the board.

Let's check something.

When you sometimes boot and can't enter the bios, does it give you any message to enter and recover the bios settings? Pressing F1 should let you enter the bios.

If it's not letting you enter the bios at all, what q-code is it haulting on?

No. The only thing I see is the ASUS TUF gaming logo with normal messege about pressing F2 or DEL to enter BIOS. Pressing those buttons does nothing. I didn't check pressing F1, but I will wait for another occurance. All this time when it's stuck, the green LED is visible on the motherboard. I do not have a LED screen for error codes for debuging on my motherboard. It's kinda a shame, It could be very useful here.

Thank you,

The green led is the boot light, it should come on, boot, then go off.

When you checked your ssd, you said it looked like it wasn't installed correctly.

When you insert it into the M.2 slot, push it in until you hear a click, you'll know then it's fully seated.

Let us know if it happens again and if pressing F1 lets you in the bios.

I have the exact same problem on an Intel system.
I've already tried all possible solutions.
For me, the problem occurs mainly during a reboot.
When I boot the PC for the first time, everything works and it boots into Windows.
However, if I restart it after a while, it also gets stuck at the ROG logo.
The problem is that this behavior occurs sporadically.
It may be that several restarts work without problems, and then without any change being made, the PC hangs again at the ROG logo on each restart.

What I've done so far:

Replaced entire RAM.
Both SSD's replaced.
Reinstalled Windows several times.
BIOS reset to default.

All drivers and firmware are up to date.

Current BIOS is 0904


i9 13900k
64GB Corsair Dominator RGB Platinum 5600Mhz
2 x Samsung 980 Pro SSD 2TB