Showing results for 
Search instead for 
Did you mean: 

TUF Gaming B650-Plus (NON WIFI) Bios page does not have any bios

Level 8

I was on the process of updating my bios and I noticed that this page has 0 bios versions available... only the WIFI version of this motherboard has bios available on the support page

I cannot update my bios at all because, as you all might imagine, neither the bios flashback nor the ez utility to update the bios recognize the WIFI's bios as valid. Is there another page I am not aware of to download the latest bios? What am I supposed to do here?

Thanks in advance.


Super Moderator

Hi Roger,

Try this URL.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Unfortunately it is empty as the other. Tried to upload a screenshot but it's giving me and error.

See my link. They are the actual official BIOS downloads.

Just checked your link and it seems legit! I think you just solved my problem. All that is left is to understand why do I have to fallback on the community for my BIOS updates.