cancel
Showing results for 
Search instead for 
Did you mean: 

[Solved/RMA]TUF GAMING B650M-E WIFI wifi driver cannot be installed

deBananedieb
Level 7

Edit: Solved -> RMA’d the board

Hello Ladies and Gentlemen

I’ve bought a TUF GAMING B650M-E WIFI Board. 

Issue is: Wifi neither showing up in device manager nor windows network connections. 

What I tried so far (reinstalled Windows 11 twice and once Windows 10): Downloading and installing drivers from the official support page (https://www.asus.com/motherboards-components/motherboards/tuf-gaming/tuf-gaming-b650m-e-wifi/helpdes...). First installed chipsetdriver networking, Bluetooth & LAN showed up under windows & device manager, no signs of wificard. Afterwards installed amoury crate, scanned for drivers, it updates & installs Bluetooth, LAN and Audio drivers, no signs of anything wifi related nowhere. 

When I try to install the Mediatek driver from the support page, UAC asks for permission, I confirm then for a fraction of a second a command prompt pops up and closes and nothing happens. Also tried to point device manager manually towards the mediatek file. 

I did this in variying orders, e.g. 1. amoury then wifidriver the chipset driver, with fresh installs of either windows 11 and 10. I updated my BIOS to the latest version 2412. Wificard is enabled in BIOS. I did CMOS after the update. I watched the video from Asus on this topic. I consulted r/buildapc Discord support. I am lost. 

 

pls help

thx

328 Views
0 REPLIES 0