cancel
Showing results for 
Search instead for 
Did you mean: 

ROG STRIX X670E-E GAMING WIFI

Pino78
Level 7

After the latest Firmware upgrade 2007, my NMVE 970 EVO is not detected any longer on the M.2_2 port.

I had a similar issue even with the previous firmware during a cold boot; the NVME was not detected.

The NVME drive works because as soon as I changed port to M.2_3 and M.2_4 it worked right away.

Is anyone having the same issue? 

321 Views
6 REPLIES 6

Silent_Scone
Super Moderator

Hi @Pino78 

Can you confirm if the behaviour is the same with EXPO overclocking disabled?

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

unclebarrycb
Level 7

Hey,

I have the exact same motherboard and have tried a Samsung 980 EVO drive and a 970 EVO. Only since the last bios update it started to not detect after being powered off for sometime, however a reboot and the system will pickup the drive. I know its not the drive as I have moved my drives to different slots and they work fine and always get detected. Only having this issue on M.2_2 port. I can't roll back to an earlier bios either and its super frustrating. Would love to see a fix as I have tried everything I can possibly think of. The drive will work after a reboot when its not detected, and when its not detected you can't see the drive in the bios or in windows its almost as if the M.2_2 slot isn't getting power or working at all until the system reboots. Then it will pickup and detect the drive, it will work fine for hours until I power off the system for the night or a couple of hours. Please let me know if anyone has a fix as I use all 4 available M.2 slots on my board. Originally had the boot drive in M.2_2 and my system wasn't booting up, once I moved the boot drive to slot 1 it has always booted into windows but the drive in slot 2 goes undetected. 

my system specs ROG STRIX X670E-E, AMD Ryzen 9 7950X3D, Cosair Dominator Ram 2x32GB 5200hz, Zotac 4090 GPU, 2x 2TB Samsung 980 EVO's, 1TB 980 EVO, 2TB 970 EVO, and a 2TB WD sata drive

Hi @unclebarrycb 

As per suggestion to the OP, I’d encourage you to confirm the behaviour is the same at UEFI defaults with no EXPO to rule out unstable OC

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

hey, @Silent_Scone 

I had reset bios to default and turned off DOCP yesterday and today when I booted up the drive was detected, I will continue to monitor over the next few days and hope this resolved my issue! @Pino78  have you tired this and did it work for you?

Thanks guys!

Hello @unclebarrycb,

I will disable and move the NVME SSD back to the M.2_2 port sometime this weekend; when I find the courage to disconnect my 4090 RTX once again.

So, let's say that after I disable the EXPO my NVME is detected on the M.2_2 port... 

Does it mean that I have to decide between having MAX Performances (EXPO) or MAX Compatibility?

Is this a Firmware issue or..?

 

@Pino78 

I mean if your not using all the M.2 slots and its working fine for you on the other slot I guess you really don't have to change anything. I was just curious if this fixed your problem. Also I don't know if this is a BIOS issue or not, but I only started to have the problem since upgrading to firmware 2007. Would really like to know what the cause and fix is. My drive would detect in the slot in question after a reboot and yours isn't detecting at all.. very strange but similar. I just hope its not a faulty board. I am going to continue to monitor and see if it goes undetected again with EXPO settings off and bios defaults loaded.