cancel
Showing results for 
Search instead for 
Did you mean: 

ROG STRIX B650-A GAMING WIFI - I keep getting ''ACPI_BIOS_ERROR'' bluescreen, can't boot!

Wzl007
Level 7

Hi there,

I recently bought ASUS ROG STRIX B650-A GAMING WIFI along with Ryzen 7 7800x3d CPU and CORSAIR VENEGANCE 2x16GB DDR5 6000MHZ, I have installed everything as it should be, it booted fine, everything seemed to work nice, even booted a game to see how it performs, everything seemed as it should be, then I decided to do some updates via ''Windows Updates'', as soon as it finished installing new updates it asked me to restart the PC which I did but then after showing the ASUS Rog Strix logo at the beginning of booting, a bluescreen showed up with this error ''ACPI_BIOS_ERROR'', I have tried any solutions I could find online but nothing worked, I updated the BIOS to the newest driver, changed AHCI to RAID, Enabled and Disabled CSM, reseated the CPU and cooler, installed all the components again, I wanted to install windows 11 again but it won't let me, as soon as I boot the USB with Windows installation it only shows Windows logo and bam, bluescreen again and rebooting happens. I decided to try and install Ubuntu to see whether it will allow me and it did allow me, Ubuntu installed just fine, everything seems to work just fine on Ubuntu, no issues, so I thought perhaps if I install Ubuntu it will let me install Windows but no, even with Ubuntu installed it won't let me boot Windows installation because as soon as the first pre-installation Windows logo shows up it keeps showing the bluescreen error, I'm out of ideas, like I said, after the first booting everything worked as it should, everything got messed up after the updates I got from Windows Update. What can I do?

Also forgot to add, when it starts booting, there's a LED light sequence happening at the beginning of booting on the motherboard, DRAM is orange/amber, then it goes to RED on CPU LED, then White on VGA and Green on the last one, but I noticed before Ubuntu install that it was mainly DRAM that had orange/amber light on, is that supposed to happen? The first time I booted I think it didn't do the light sequence.

244 Views
1 REPLY 1

Wzl007
Level 7

It's weird that Ubuntu works normally, games work too, as if all the components work as they should but I can't install Windows while on this motherboard, it keeps popping up with ACPI-BIOS-ERROR as soon as I boot Windows from the USB stick, any help would be highly appreciated as I've been struggling with this for the last 3-4 days now and can't fix it, I don't want to be stuck in Ubuntu as I prefer to have Windows.