cancel
Showing results for 
Search instead for 
Did you mean: 

rog strix 650e-f - no power in newly asembled pc

pucha85
Level 7

Hi,

i have an issue with newly assembled PC. I have just connected all parts, but when i press power button nothing happens. All parts are new, just purchased them today.

Parts :

Corsair rm 750e

ASUS ROG STRIX B650E-F GAMING WIFI
Ryzen 5 7600
corsair ddr5 (2x16gb) 6000mhz cl30 
pearless assassin 120se
kingston m.2 ssd 1tb
rx6600
1tb wd sata ssd (old)
montech sky two case (with build in fan hub)

I have connected all parts, connected power cables etc. and when i turn on PSU from 0 to 1 i can see that asus rgb on motherboard is lighting (seems psu might work?), but when i press "power" nothing happens (no psu fan - maybe it's because corsair under load doesnt spin, but also no case or cpu fans are spinning either.

front panel seems to be connected ok, as there is no other way to connect power.

What have i done so far to troubleshoot:

  1. removed graphic card from

  2. disconnected usb panel , audio panel

  3. disconnected old ssd, removed m.2 drive

  4. re-connected all power cables (atx (big one) and 8pin + 4 pin to CPU

  5. tried with atx big one and just 8pin for CPU

  6. connected cpu fan to 2 different slots (main/AIO)

  7. disconnected splitter from pearless assassin and connected 1 fan directly. Also i have tried with stock cooler.

  8. changed cable slots in corsair psu

  9. removed ram, tried with 1, with 2 and with all possible slots

  10. tried to unplug power switch and used screwdriver to power on PC, also no luck (to eliminate faulty case)

  11. made paper clip psu test as i dont have manometer- seems to be fine
  12. tried to flash bios from usb (2 latest versions)
  13. tried to reset cmos

What other options do i have? im basically out of ideas. im leaning towards DOA 😞

PS. i dont have any other PC which i can test parts from

151 Views
2 REPLIES 2

KedarWolf
Level 10

One time I had a stand off in the case in the wrong spot and shorting  the the motherboard, another time a screw had fallen under the motherboard and was shorting it out. Both times PC wouldn't turn on.

thanks for tip, but forgot to mention that mobo was eventually taken out from chassis and tests sere repeated without any luck