Showing results for 
Search instead for 
Did you mean: 

ROG CROSSHAIR X670E HERO problem with drive speed

Level 10

System:   7950X3D/X670E Hero/2x48 Gb F5-6400J3239F48GX2-TZ5RK/1Tb Kingston KC3000+2Tb Samsung 990 PRO+2x4Tb Kingston Fury Renegade+2x4Tb Kingston XS2000/RTX 3060/SS-1200 XP3/NH D-15S/ BIOS 1709

Something is not very good with Asus on this AM5 platform (and maybe not only with Asus). I can’t understand what is causing the problem of periodic slowdown in the speed of all drives, as if the chip goes into some kind of energy saving mode and cuts the speed to a minimum. I thought there might be a problem in SATA - I removed all hundred disks and left purely high-speed drives from Kingston and Samsung of the latest generations, but the problem with the speed dropping to 70-100 MB\s 15-30 minutes after the system was started or after a long period of inactivity did not disappear, or when nvme is actively used in audition or the like. - as if the chipset goes into energy conservation and allocates a minimum of speed for the operation of the drives. I don’t think that this is a problem in Win 11, since I even booted from the live SD of Win 10 and the problem happened again.
The only solution that I found was that at the moment of a drop in speed, take me to start a banal copying of a large array of large files of 20-50 Gigabytes in size, and then after 30-60 seconds, the chipset seems to come to life and restore the speed to 3-5 GB / s. For half a year now I can’t understand why NVMEs work so poorly on the x670 Hero..... before that there was a Hero on the z390 I -9900K - there was no such crap with the operation of the drives - they always worked at full capacity. I am sure that 999% of users will not even notice such a problem, but my disks are used very actively for caches, etc. and I observe all these lags after each BIOS update.

I tried it on a clean system without drivers and with the latest drivers - the problem of a temporary drop in drive speed to minimum values ​​(70-100 MB/s) is always observed - and with the latest drivers for both Windows 11 and Windows 10. Therefore, I think that This is purely a problem in the very logic of the x670E chipset, which periodically wants to enable a hidden power saving mode

Copying two large file 30 Gbs while slowing down from 4Tb Kingston Fury Renegade  on 2Tb Samsung 990 Pro ....... t takes about 10 seconds before the speed becomes maximum again, but sometimes 30 and 60 seconds - I haven’t noticed a pattern on what this depends



Level 8

This may help or it may be a totally different problem. In iRacing every time I start a session after 4.45 to 5.00 minutes it would slow to a crawl,,, from 240fps down to between 4 to 18fps for about 30 seconds and then it would be good and no more troubles in the session.

Turns out the solution was USB related and going to power options  disabling the USB and it works perfectly,

Control panel / System and Security / Power Options / Change Plan Setting / Change Advance Power Setting/USB Settings 

This all doesn’t work, the best effect was achieved when I strictly specified the PCI-E type in the BIOS, namely 4.0 - landings began to occur a little less frequently, but still repeated

I don’t know, there’s a feeling in the logic that during a long period of inactivity the entire chipset goes into some kind of super sleep mode from which it cannot automatically wake up for some reason

I don’t think this is somehow related, because you have a completely different platform

im on a x670e and 7950x ?

1) The first link you have is for z790, it’s not x670E
2) The SSD in your T700 is gen5 and as I understand the problem with it is that the board does not see it or does not work normally in gen5 mode

3) I currently have all four SSD slots filled with gen4 SSDs (Kingston KC300 1Tb in first port m2, Samsung 990 Pro 2Tb in second slot m2 and two Kingston Fury Renegade 4TB  in last slots), they are all normally detected in the BIOS system, have speeds close to nominal (only in the two lower m2 it is slightly lower than the factory 6500 versus the declared 7300), but the problem is different - I notice that after a reboot after 10-30 minutes or after a long period of system downtime, at some point the speed of the entire disk system drops to 70-100 MB /s, but does not automatically return to normal speeds 6000+/6000+ MB/s you have to force copying of large files from one SSD to another, so that after 30-60 seconds the speed returns to normal, in my opinion this is absolutely not what you are writing about....

Level 10

For me, this is a globally painful problem, which has not been solved in any way since spring..... most likely before the New Year I will have to buy a new motherboard, but just hide the MEG Godlike or ACE from MSI, most likely there are no problems with this, after all, I have not encountered such offensive incidents on the Internet regarding these motherboards, and the asus will most likely go to waste