Showing results for 
Search instead for 
Did you mean: 

ROG Crosshair X670e Extreme Matrix LED and OLED

Level 8
Hey there, got a little problem with my Crosshair extreme.
OLED Screen seems to be posting fion during boot, but reaching windows it displays only "memory test".
Matrix LED is just switchable in bios to on and off. Some LEDs are turned on but there is no more animation. So far I did not install crate crap. Any advises to get the display and the matrix back to working?

Level 8


I have the same motherboard with the exact same problem! I updated to the most recent BIOS today and still no luck. The memory I have is listed on the QVL as well and this is the second pair different brand still get the same issue. I can still boot just fine into windows and game or whatever but it's odd that this is happening when it was working just fine when I first built the system.

I have a ASUS Extreme 670E and the AniMe Matrix used to work but stopped working when I changed my computers power supply.

Tried uninstalling the Armoury Crate, reinstalling it,even flashing the BIOS to the latest version. Still no AniMe Matrix display anymore. The OLED screen still works.

Armoury Crate appears to be full of bugs.

I am running the latest version of Armoury Crate. 

ASUS please fix this issue. 

Level 10

The problem with The OLED - Display was fixed with the new bios version 1516. A new firmware will be installed with the New Bios. That's why multiple restarts.

BUT I had to reset the Bios twice afterwards (?). Now everything works again. When starting, each device is now displayed when starting and the code behind it!

Such as: "CPU Code: ..." "VGA Code: ..." And after the success the beautiful animation with the fighter.

AMD Ryzen 9 7950X3D | ROG CROSSHAIR X670E EXTREME | ASUS TUF Gaming GeForce RTX 4090 OC | G.Skill F5-6000J3040G32GX2-TZ5N | WD Black SN850X | PHANTEKS Glacier One 360 T30 Gen2 | LG OLED42C27LA | Phanteks NV7 | Seasonic PRIME-TX-1300